Sep 1, 2021
1
0
10
0
Hello,

I have cordless desktop Logitech S520 and I am quite with him. But some days ago I encountered on problem I still cannot explain. My mouse suddenly started to blink red on the top LED (low battery) and green on the down (on/off LED). I tried several pairs of batteries - no matter how full batteries are, blinking remains. The only thing which can stop blinking is pressing button "connect". But it does not bring anything, mouse does not connect and blinking continues as soon as I stop pressing "connect" button.

Yesterday I disassembled mouse to check if everything is OK. So, I cleaned all buttons, all cables - no result. In the meantime I think, that I experience some electronical isse on the board.

So, I want to ask a community here: did anyone experience this problem too? And if yes - what was a solution?

Thanks in advance.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

With all due respect the peripheral combo is just a little over a decade old at this point, since it was released. I'm sure you could use come contact cleaner for the innards of the mouse and also try and inspect every square inch of the mouse's PCB to see if any component might be burnt. As for the mouse, is it possible that the device was searching for a device in spite of being tethered to your platform?

I've worked with Logitech mice over the years and the cordless version that I got in my region, Bangladesh, all died a day before the warranty period failed or a little after the warranty period failed.

One user suggested interference on this thread;
https://superuser.com/questions/330986/logitech-lx5-cordless-mouse-freezes-unexpectedly-and-green-light-always-turned-o

Have you tried reconnecting the mouse with the adapter?
 

ASK THE COMMUNITY