[SOLVED] Mouse pointer jumping, system 32 folder in quick access and more ---- possibly malware ?

Dec 7, 2021
4
0
10
0
Since yesterday, I've been facing a problem that's been a pain in the butt.
Early at morning, at around 11 am (in israel, dunno wether it's IST or others), I downloaded and installed a windows update to my pc.
Everything went fine before the restart.
After I restarted my pc, first thing I saw was that my mouse pointer was, and still is, "jumping" when I move it.
ie. it looks as if it's teleporting after I move it, it takes a millisecond or so to move forward every second I move my mouse.

Now, at first, I was sure that maybe my screen got disconnected and reset back to 60hz, so I went and checked that first.
Turns out my screen was fine and it was set to the highest Hz.
So, I start surfing the web, looking for answers, and no YouTube vid has helped me yet.
Afterwards, I went to the LTT discord, to maybe get some answers - people tried helping, but no good result came out.

Now, this is where the "possibly malware" comes in because from what I've read on the internet, mouse jumping can occur from malware.
Earlier, I had already scanned my pc FULLY using Malwarebytes, and there were no detections
After I realized that the problem can occur from malware, I went ahead and used Windows Defender this time to fully scan my pc again, and just like w Malwarebytes, no detections.

The day before I had this problem, I downloaded an alpha version of cube world (wanted to play w friends)
Now, this could be what might've Fd my pc up, I'm not sure yet - when I get back home I'll check on it and delete it, in hopes that it'll fix the problem.
Anyways, back on track.

Later that day, I started noticing other problems, such as: system32 in my quick access tab, my snipping tool was removed from my taskbar, and when I was in a call with friends, I turned my camera on and it after a bit, it displayed the thing you see when you punch a screen (sorry, I rlly dunno a word for that). It was all green and rlly weird, and afterwards, it just turned solid green, and the camera just shut down.

Also, in videos on YouTube and video games, it's been doing the same problem - feeling as if the video cuts back a millisecond, or in a video game, the mouse is not as responsive.
I really hope you guys can help me with this, any suggestions I tried I will let you know, I even upgraded to win 11, I feel lost and very worried for my pc, and the last thing I wanna do is a total wipe.

Thx in advance.
 

ASK THE COMMUNITY

TRENDING THREADS