Question Mousepad lag

Jul 19, 2020
8
0
10
0
So when I use any mousepad, used or completely new, logitech, hyperx, zowie etc. my mouse feels heavy, sluggish, whereas on my table it is clean **** but the only problem is that it is slippery.

[Note: **** = Moderator edit to remove abbreviated profanity. Remember that this is a family friendly forum. ]

Also I tried with a few different mice (steelseries, logitech, zowie) and the one I use currently is Logitech G Pro

Need ideas :(
 
Last edited by a moderator:

Colif

Win 10 Master
Moderator
have you tried a mousepad made by the same people as Mouse? It might work better, I have a steelseries mouse and mousepad and it really depends on how mouse is configured as to how sluggish it feels. After getting new PC I thought my mouse pad was slowing mouse down but once i went into drivers, it told me that Windows mouse acceleration was interfering with the native mouse precision, and upon allowing the software to turn it off, my mouse feels much better now on most surfaces (besides a blanket but thats obvious)
 
Jul 19, 2020
8
0
10
0
Yes. Before it all happened, my always go-to mousepad was the Logitech g640 and I have a few of them. I not only cleaned those but bought a new one of those to make sure and this does not work either... About mouse acc, you mean the option to 'enhance mouse precision? (I have it OFF)
 

Colif

Win 10 Master
Moderator
does it matter if its in wired mode or not?

reddit link
 
Jul 19, 2020
8
0
10
0
This is a different mouse we are talking about. I am currently using the G pro that is ~60 euros, while the G PRO Wireless is 130 euros (it can be used wirelessly, as well as wired). It has the last censor and is their newest one. I bought it 2 days ago to try it out but returned it the day after as It was not the solution.
 
Jul 19, 2020
8
0
10
0
The thing is that I reinstalled windows 100s of times and also send it to a service where they cleaned it fully from the inside (all the parts, checked that they work flawlessly and reinstall windows as well). It did not work. I also asked a friend for his PC which is almost equivalent to mine in terms of capabilities, (mine has i7 8700k, 1060 6gb nvidia, 16 ram etc. ) and the lag still exists there so it can't be from my PC. I thought it could be an electric issue and tried everywhere around my house, it did not work. My monitor is 240hz and during the summer I thought it was the problem so I explained it to the seller and they gave me a completely new one with the same model, it did not work either :(.

I will try ubuntu now but do you think it could fix anything that I haven't already tried?
 

ASK THE COMMUNITY

TRENDING THREADS