MS04-021/Q841373 IIS 4.0 update conflict with Proxy 2.0?

chaos

Distinguished
Jul 16, 2001
84
0
18,630
Archived from groups: microsoft.public.windowsnt.misc (More info?)

I've just installed the MS04-021/Q841373 critical update to our NT 4.0 server that runs our Proxy 2.0. Our client computers are now not able to connect to the internet using that server's Proxy. The error message at the server when clients try to connect refers to the server's inetinfo.exe. When I uninstall that critical update from that NT 4.0 server, Proxy works fine again. Is there a conflict in this combination? Anyone else have the same problem? Thanks.
 

Andy

Distinguished
Mar 31, 2004
1,239
0
19,280
Archived from groups: microsoft.public.windowsnt.misc (More info?)

Yes, we had exactly the same problem after installing the
MS04-021/Q841373 patch. As soon as a client PC attempted
to connect to the web we had a Dr Watson's error on the
server referring to inetinfo.exe

Proxy worked fine after uninstalling the patch.




>-----Original Message-----
>I've just installed the MS04-021/Q841373 critical update
to our NT 4.0 server that runs our Proxy 2.0. Our client
computers are now not able to connect to the internet
using that server's Proxy. The error message at the
server when clients try to connect refers to the server's
inetinfo.exe. When I uninstall that critical update from
that NT 4.0 server, Proxy works fine again. Is there a
conflict in this combination? Anyone else have the same
problem? Thanks.
>.
>
 

chaos

Distinguished
Jul 16, 2001
84
0
18,630
Archived from groups: microsoft.public.windowsnt.misc (More info?)

According to one of MS's workarounds (without installing the patch), you need to make sure all hosted web sites in IIS DO NOT have Redirect set under the "Home Directory" tab. I am going by this unless someone can suggest a better solution that doesn't require us to upgrade, etc, or unless someone tells me this doesn't work?