[SOLVED] MSI 3060 Ventus 3x 12GB OC not recognised in Windows

Status
Not open for further replies.
Nov 21, 2020
7
0
20
0
I am having no luck trying to get my new MSI 3060 Ventus 3x 12Gb OC to be recognised by windows 10. I have an ASUS z270 prime with an i7-7700k, 32GB RAM and a Corsair 550W PSU. I have updated Windows and set the the BIOS to PEG and Gen3 with the primary display on PCIe 1. What ever I do I get a windows generic display driver. I thought the issue might have been the PSU but he MSI specification for this card recommends 550 watts and the card is rated at 170 Watts. The card fans spin up but I am getting nowhere. I used DDU to uninstall the previous GPU AMD RX580 Nitro + in safe mode. I have tried to use MSI Update live but that doesn't detect anything, I downloaded MSI dragon also. I even tried downloading the NVIDIA updater and it told me that it wasn't compatible with my hardware, presumable because the card isn't detected. Anybody managed to solve this issue? I am at the end of my tether!!!
 
Nov 21, 2020
7
0
20
0
I managed to get it working. The card was actually being recognised by the motherboard which I could see in the BIOS so it had to be either drivers or windows. The MSI software is crap and didn't detect a thing and they don't have a stand alone driver. I had already tried to use the dedicated NVIDIA app but it failed and threw an error saying that my system wasn't compatible. I didn't realise initially that I could just load the NVIDIA driver so as soon as tried this it worked and the card appeared in the device manager. Total pfaff, MSI drivers app is pants!
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS