Question MSI 750Ti not working on MSI B75A-G41 motherboard ?

Feb 27, 2021
2
0
10
0
Hello,

a friend of mine gave me his old msi 750Ti (Twin Frozr). I tried to put it into my PC:

msi B75A-G41
Intel i5 3570
Team Elite 2 * 4 GB DDR3 1333 MHz
be quiet S8-400W

But the monitor does not receive any signal neither via VGA nor via DVI. My friend said that it was still working the last time he used it.
I already tried
  • explicitly turning off the On-Board Graphics in the BIOS
  • disabling PCIE Gen 3 in the BIOS
  • uninstalling the drivers
  • reinstalling the drivers
  • setting "Initiate Graphic Adapter" to both PEG and IGD
  • putting the card into the other PCIE slot
I'm triple-checked that there is no hidden 4pin or 6pin on the GPU. The PSU's output should be enough to power the card.

I can't seem to find an option in the BIOS to disable CSM / Legacy Boot nor Secure Boot.

The card has a tiny switch on it that is labeled SW-BIOS. I tried both positions.

What can I do at this point? Thanks for any help in advance.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

How old is the PSU you've listed in your specs? What is the make and model of your friend's PSU and it's age? I don't think the GPU is the issue, more like your PSU is unable to power a system with a discrete GPU installed. Did you use DDU to uninstall your GPU drivers before you dropped the discrete GPU into the system? I'd also ask you to look into the BIOS version for your motherboard and see if it's got any BIOS updates pending. If you do have updates, don't jump to the latest, gradually work your way to the latest.
 
Feb 27, 2021
2
0
10
0
Hello,

The psu itself shouldn't be older than three years. My friend was using some noname psu with 500W.

The suggested psu, according to the gpu's datasheet, would be 250 W, so mine should be more than enough.

If I put the gpu into my pc the gpu's fans spin up so I guess there should be enough power.

I'm using linux so DDU isn't a thing. I'll look into uefi updates later today and report back.

What I'm wondering is that all parts in my pc are some years newer than the gpu and still the gpu isn't detected in neither the bios nor the OS ?
 

ASK THE COMMUNITY

TRENDING THREADS