• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question MSI A320 Vd/S V2 - Bios Update - No Display-CPU Light on EASY DEBUG.

Nov 4, 2019
2
0
10
0
Hi, I was working on a new pc build. Got it running good. Went to bios of my MSI a320 pro vd/s V2 motherboard. And version was E7A36AMS. A4N. So i wanted to update my bios and went to msi site to download 7A36vA2 (https://www.msi.com/Motherboard/support/A320m-Pro-vd-V2).

After 100% completion of bios update through M-Flash it restarted but didn't turn on display. Now the system is not giving any display and MSI Easy Debug Mobo light of CPU is flashing but I am not able to boot anything. Please help? I just bought this motherboard on 1st Nov 19.. Now i can't use this brand new pc. Please anyone assist.

I had formatted the flash drive to fat 32 before update. I am running Ryzen 5 3400G with 8GB Corsair Vengeance 3000mhz.

The bios update drivers files were downloaded from msi website after specifying the model.
 
Nov 4, 2019
2
0
10
0
It need the A4 to run 3400G. why did you down grade it?
take it to a shop to update it back. or contact msi

see the support cpu list with the bios version required
https://www.msi.com/Motherboard/support/A320M-PRO-VDS-V2/#support-cpu
Hey Thank you for the response. I didn't know that was the lower version. It was coming right on top in latest driver for Motherboard. Such a newbie mistake. Anyway i took it to MSI Service Center (in India) and they fixed it in 10mins. haha! thanks for your help! :)
 

ASK THE COMMUNITY

TRENDING THREADS