Question MSI Afterburner reading my CPU temperature as 207 degrees C

Jan 21, 2021
12
0
20
1
Hello, Recently (Basically today), my MSI Afterburner's been acting strange. My CPU temperatures are being measured at 207 degrees C, which is outrageous. But when I check my CPU temps via HWInfo, it's regular. I have installed all CPU and chipset updates, and nothing worked. I am perplexed and need help. If I switch the data provider to hwinfo.dll, nothing appears, same with aida64.dll.
Here's what it looks like on the graph. Note how the data provider is cpu.dll.

But if I set the data provider to hwinfo.dll or aida64.dll, this happens.

I am insanely confused on why this is happening. a quick answer would be greatly appreciated.
 

lvt

Commendable
Apr 19, 2021
1,728
277
1,640
40
It's ridiculous, even in Fahrenheit.

I never trust a single app when it comes to reading the motherboard's sensors, I always compare the results from two apps, or sometime from the Bios.
 
Jan 21, 2021
12
0
20
1
I use HWinfo for CPU stuff. BTW, my OSD toggle for Afterburner stopped working, hitting the "\" key doesn't toggle it on and off.
 
Jan 21, 2021
12
0
20
1
If you haven't already you should uninstall Afterburner and update to the latest version...many times a simple driver update on your system can break functionality in older versions of Afterburner.
I just installed the newest version. If I set my CPU temperature to hwinfo.dll on Afterburner, nothing appears.
 

ASK THE COMMUNITY

TRENDING THREADS