Question MSI B450-a pro crashed?

i_spot_the_not

Distinguished
Apr 8, 2010
11
0
18,510
0
Hello everybody!
I am an old school entusiast that have updated his pc last year.
My config is:
MSI b450-a pro
Ryzen 5 3600
HyperX Predator HX432C16PB3K2/16 DDR4 2 x 8 GB, 3200 MHz CL16
Sapphire Radeon RX5700
PSU Corsair HX620

Yesterday I was using the PC and it crashed (black screen). After that it didn't reboot. Screen was just black.
Monitor is working because i have tried with another PC.

During fail boot tentative, Motherboard debug led - CPU was ON.
Tried different times with no success.
Tried leaving without power for long and it did boot but freezed in windows login screen.
Tried another PSU (Evga nex750) with no ssd went into bios
Tried again with the Evga with ssd: black screen and Motherboard debug led - Boot and VGA were ON
Tried with original PSU with no ssd: black screen and Motherboard debug led - Boot and VGA were ON
Tried with original PSU with no ssd and no VGA: black screen and Motherboard debug led - Boot and VGA were ON
Remover bios battery for 10 minutes, tried with original PSU and no VGA an no ssd and no debug led is on but black screen.
Tried with original PSU, VGA and no SSD and Motherboard debug led - Boot, VGA and RAM were ON but black screen.

I don't know what I should try.
Thanks
Regards
 

bizzybg

Reputable
Jan 15, 2016
33
0
4,530
0
Did you try removing your GPU and connecting the monitor to Motherboard video output? Does it even show BIOS or not? I've seen someone with the same issue some days ago.
 

i_spot_the_not

Distinguished
Apr 8, 2010
11
0
18,510
0
Thanks for the reply
Yes, I have tried. Black screen.
I didn't remember if I have disabled the onboard gpu, so I tried to remove the motherboard battery to reset it.
 

ASK THE COMMUNITY

TRENDING THREADS