Question MSI B450 Carbon CPU light no post after PSU swap

TwistedFury

Honorable
Nov 1, 2013
707
0
11,160
55
Hey, so I was upgrading my PSU and case and when I tried booting my B450 Cpu light is staying on. I moved to a breadboard and used my previous PSU and even with that this CPU light is staying on. It worked before I worked on it.
I've tried doing just 1 stick of ram, clearing cmos, I've double checked all the plugs, nothing, I'm at a loss.
Ryzen 3700x
GTX 1070
16GB DDR4-3600 Corsair.
 

Darkbreeze

Titan
Moderator
Apparently, you haven't checked ALL the plugs, because something is different than before. Make sure you didn't accidentally knock something loose or skew one of the connections a little bit while working in the case.

Typical things to look at in this circumstance where no other hardware was changed are to ensure that you have re-attached AND fully seated the 4+4 (8 pin) EPS 12v CPU power connection along the top edge of the motherboard, 24 pin fully seated, check the memory to make sure one of them didn't get loose, check the CPU fan header connection because it's very easy to bump that free. Pretty much remove and reseat the memory and graphics card and triple check every single item listed at the link below. In fact, it would be wise to unplug and then reconnect each and every connection, just to make sure you are not overlooking something simple. As well, be sure you are not trying to use the PCI power connectors for the EPS/CPU and visa versa.

 

ASK THE COMMUNITY

TRENDING THREADS