Question MSI B450 Tomahawk MAX - M2 SSD Problem - Half Speed

Feb 9, 2020
4
0
10
0
Hi,

I have assembled a computer:
Board: MSI B450 Tomahawk Max
Processor: Ryzen 2700
Disk: M2 Samsung 970 Pro 512 GB,

I'm worried about transfers in reading and sequential writing on the M2 port, as they reach max 1.5 GB / s, which is half of what should be.

The disk works in PCIe 3.0 x2 mode but should be in PCIe 3.0 x4, I do not know how to change it, I reviewed the whole BIOS and found nothing.

I tried different versions of the bios and it did nothing.

If this was a fault, where do you look for the cause, motherboard, disk, processor?
 

taeioum

Commendable
Jan 27, 2019
522
78
1,340
68
I think you're right about the PCIe x2 thing. It should be set to x4 in the BIOS (or UEFI if you want to be nitpicky) just like you said.

Problem is that I can't find a video that shows how to change this setting. What might work is the search functionality in the top right of the BIOS screen. Between the F12 button and the Language button there's a Search button. You might be able to find what you're looking for if you simply type "PCI" in the screen that pops up.

If you can't manage to find it, my brother-in-law has the same motherboard. I'm going over to their place in less than 2 hours. I should be able to supply some screenshots if wanted. Let me know!
 

taeioum

Commendable
Jan 27, 2019
522
78
1,340
68
I actually remembered to check but forgot to reply..

But uhh, I'm afraid you're right, at least with the BIOS version on the motherboard I got my hands on. I can't find any setting at all regarding x2 or x4 speeds on the M.2 slots. Nowhere at all. Yet my brother-in-law has an ADATA XPG SX8200 Pro and his is working fine on x4..

Do you perhaps have a SATA drive hooked up to SATA port 5 or 6? If not, is the actual SKU of your drive the MZ-V7P512 serial? Just trying to figure out if it's somehow not supported.
 
Feb 9, 2020
4
0
10
0
Taeioum, thank You for reply.

Yes, model of my disk is: MZ-V7P512.

It's strange, there is such a sentence in the specification "SATA5 and SATA6 ports will be unavailable when installing a M.2 device in M.2 slot.". But I installed another SATA SSD Dysk in port SATA6, and it and works with the m2 disk although it shouldn't.
Maybe this will be a tip
 
Taeioum, thank You for reply.

Yes, model of my disk is: MZ-V7P512.

It's strange, there is such a sentence in the specification "SATA5 and SATA6 ports will be unavailable when installing a M.2 device in M.2 slot.". But I installed another SATA SSD Dysk in port SATA6, and it and works with the m2 disk although it shouldn't.
Maybe this will be a tip
I think thats your problem as you are forcing it to share pcie lanes between the M.2 slot and Sata 5&6.
 
Feb 9, 2020
4
0
10
0
Ok, the problem is solved, the disk heatsink was wrong, which was mounted incorrectly and the disk connector did not enter the M2 slot, I improved the heatsink and I have PCIe 3.0 x4, and transfer 3.5 GB / s read, 2.3 GB / s write on the m2 port.
 

ASK THE COMMUNITY

TRENDING THREADS