Question MSI B450 TOMAHAWK MAX & Ryzen 5 3600x sluggish and low userbenchmark score

Mar 23, 2022
4
0
10
0
Hello, i am running windows 11 pro all updated, latest drivers from msi and current firmware. PC setup and userbenchmark score

Similar builts are showing great results but mine is just in dumps.
UserBenchmarks: Game 8%, Desk 33%, Work 6%
CPU: AMD Ryzen 5 3600X - 17.3%
GPU: AMD RX 570 - 25.2%
SSD: WD Black SN750 NVMe PCIe M.2 500GB (2019) - 105.9%
RAM: G.SKILL F4 DDR4 3600 C19 2x8GB - 9.8%
MBD: MSI B450 TOMAHAWK MAX (MS-7C02)


Computer is very sluggish, just good enough for browsing. Opening any application, browser folder get message "Working on it" and then it works after some time. HWINFO report is on pastebin : https://pastebin.com/69BXW7Xd

Thanks for your time.
 

oggyphillips

Distinguished
Feb 15, 2015
120
4
18,685
0
It looks like your memory speed is running at 2133 mhz. You can quickly check it by opening task manager, and going into the performance tab.

Your memory should be running at 3600mhz.

Check if XMP is enabled in your BIOS, this will set your ram at the desired speed from the manufacturer.
Ryzen processors perform terribly without xmp enabled.

If your ram speed is ok, then perform a stress test and check the max temps, send another pastebin if you want.

From pastebin:
  1. Memory Device -------------------------------------------------------------

  2. Total Width: 64 bits
  3. Data Width: 64 bits
  4. Device Size: 8192 MBytes
  5. Device Form Factor: DIMM
  6. Device Locator: DIMM 1
  7. Bank Locator: P0 CHANNEL B
  8. Device Type: DDR4
  9. Device Type Detail: Synchronous
  10. Memory Speed: 2133 MHz
  11. Manufacturer: Unknown
  12. Serial Number: 00000000
  13. Part Number: F4-3600C19-8GVRB
  14. Asset Tag:
 
Last edited:
Reactions: sgs007
Mar 23, 2022
4
0
10
0
It looks like your memory speed is running at 2133 mhz. You can quickly check it by opening task manager, and going into the performance tab.

Your memory should be running at 3600mhz.

Check if XMP is enabled in your BIOS, this will set your ram at the desired speed from the manufacturer.
Ryzen processors perform terribly without xmp enabled.

If your ram speed is ok, then perform a stress test and check the max temps, send another pastebin if you want.

From pastebin:
  1. Memory Device -------------------------------------------------------------

  2. Total Width: 64 bits
  3. Data Width: 64 bits
  4. Device Size: 8192 MBytes
  5. Device Form Factor: DIMM
  6. Device Locator: DIMM 1
  7. Bank Locator: P0 CHANNEL B
  8. Device Type: DDR4
  9. Device Type Detail: Synchronous
  10. Memory Speed: 2133 MHz
  11. Manufacturer: Unknown
  12. Serial Number: 00000000
  13. Part Number: F4-3600C19-8GVRB
  14. Asset Tag:
Thanks for the reply, i took steps
  1. Disabled windows update to install device drivers and have amd update to install drivers : https://www.amd.com/en/support/kb/faq/pa-300
  2. Enabled XMP in bios
Memory speed in bios still shows 2133 MHz,
 

oggyphillips

Distinguished
Feb 15, 2015
120
4
18,685
0
Thanks for the reply, i took steps
  1. Disabled windows update to install device drivers and have amd update to install drivers : https://www.amd.com/en/support/kb/faq/pa-300
  2. Enabled XMP in bios
Memory speed in bios still shows 2133 MHz,
Maybe it's failing to boot with xmp enabled and resseting the BIOS without XMP.

See if you can update your BIOS to the latest version, but be careful. You may need to update to an older version before you can update to the latest.

Your CPU is quite hot too. See if you can increase the fan curve a little bit, and save that profile. The BIOS will let you save profile of changes you make within.
 
Mar 23, 2022
4
0
10
0
Thanks for the reply, after activating A-XMP profile #2 memory in bios MHz is as expected.


As far as cpu temperature it looks good after stress test.


Thanks
 
Thanks for the reply, after activating A-XMP profile #2 memory in bios MHz is as expected.


As far as cpu temperature it looks good after stress test.


Thanks
You need to see temps while testing. What cooler are you using? Is RAM installed in slots a2-b2?

Go to userbenchmark.com and run the test. Link results here after completing benchmark. Make sure to disable any overlay before testing.
 
Mar 23, 2022
4
0
10
0
Thanks all for your help, tried all the suggestions but nothing worked. Board still under warranty so going to RMA.
 

ASK THE COMMUNITY