[SOLVED] MSI B450M Bazooka Max WiFi ---- on-board WiFi not showing up in Device Manager ?

Nov 2, 2021
2
1
15
0
As the title suggest; the onboard WiFi card on my motherboard suddenly stopped working but I can't do any trouble shooting as it does not show in device manager, nor is it detected by Intel Support Assistant.

Tried updating the bios to the latest stable version, fresh install of OS, power cycle, remove CMOS battery, restore bios default, and downloaded some bloatware "driver installers" and none seem to detect the on-board Intel Dual Band AC 3168 WiFi card, installing the driver downloaded from Intel also does not do anything.

The onboard bluetooth works tho. :3

What more troubleshooting steps could I try?
 
Nov 2, 2021
2
1
15
0
could try booting from an Ubuntu live USB and see if it sees the WIFI as it would test if its just some random windows problem. if it can't see the adapter, its not working
https://ubuntu.com/tutorials/create-a-usb-stick-on-windows#1-overview

odd BT works but wifi doesn't as often they use same chips.

if its not working, you may need to contact MSI about rma or something if its important to you.
Apparently I forgot to try the "turn it off and then on again" method.

Went into the BIOS to disable the WiFi Module Control, restarted then reenabled it again and now it's working. Just a pain that sometimes the WiFi adapter would disappear from device manager during normal use.

Will probably refrain from using MSI boards from now on.

Thank you for the help!
 
Reactions: Colif

ASK THE COMMUNITY