[SOLVED] MSI bios reverts boot priority (CLONED SSD back to old HDD)

GianMarco Douglas

Honorable
Dec 23, 2014
74
0
10,640
2
I just cloned my old WD BLUE 1TB hard drive to a Crucial MX500 500gb ssd using aomei backupper. That process was smooth. My SSD boots but only when I override it in the BIOS. My issue is when I try to prioritize my ssd over my old hdd in the BIOS. My first boot option is the UEFI Hard Disk: Windows Boot manager. I then went to UEFI Hard Disk BBD Priorities on the bottom and selected my ssd over my old hdd. When I save and reboot, my SSD is booted but the boot order reversed to my old hdd after the 1st restart. When I check the settings in the bios, the priorities revert back to the original (hdd 1st). How can I change the boot order permanently?
 
You have 2 instances of UEFI bootloaders in your system (EFI system partition on 2 drives). That causes confusion.

First - test if you can boot into windows with only SSD connected.
If that is successful, then delete EFI system partition from HDD. If you do it without testing first, then you may leave your system unbootable.
diskpart
list disk
select disk 1
(select 1TB disk)​
list partition
select partition x
(select 100MB Efi system partition, x=2 or x=3)​
delete partition override
 
I just cloned my old WD BLUE 1TB hard drive to a Crucial MX500 500gb ssd using aomei backupper. That process was smooth. My SSD boots but only when I override it in the BIOS. My issue is when I try to prioritize my ssd over my old hdd in the BIOS. My first boot option is the UEFI Hard Disk: Windows Boot manager. I then went to UEFI Hard Disk BBD Priorities on the bottom and selected my ssd over my old hdd. When I save and reboot, my SSD is booted but the boot order reversed to my old hdd after the 1st restart. When I check the settings in the bios, the priorities revert back to the original (hdd 1st). How can I change the boot order permanently?
Is the bios fully up to date?
 
You have 2 instances of UEFI bootloaders in your system (EFI system partition on 2 drives). That causes confusion.

First - test if you can boot into windows with only SSD connected.
If that is successful, then delete EFI system partition from HDD. If you do it without testing first, then you may leave your system unbootable.
diskpart
list disk
select disk 1
(select 1TB disk)​
list partition
select partition x
(select 100MB Efi system partition, x=2 or x=3)​
delete partition override
 

GianMarco Douglas

Honorable
Dec 23, 2014
74
0
10,640
2
You have 2 instances of UEFI bootloaders in your system (EFI system partition on 2 drives). That causes confusion.

First - test if you can boot into windows with only SSD connected.
If that is successful, then delete EFI system partition from HDD. If you do it without testing first, then you may leave your system unbootable.
diskpart
list disk
select disk 1
(select 1TB disk)​
list partition
select partition x
(select 100MB Efi system partition, x=2 or x=3)​
delete partition override
dude actually, restarting my computer with the hdd unplugged worked and then i repeated it with it plugged. In both cases, the ssd booted automatically. Hurray :)
 

ASK THE COMMUNITY