Question MSI Ez Debug CPU light on

flaminggamer659

Prominent
Dec 5, 2018
17
1
515
0
Hi,
I just built a PC, first time as well.
I boot the finished PC for the first time to install Windows and setup. Ez debug light comes on. I fiddle around with the components, reseating CPU, resetting CMOS etc, and then I remove one RAM stick and it all works.
I setup the PC as normal, it works, as it should. Fast forward a day and I go into the bios, realise the RAM is running at 2133mhz instead of 3200, I change that and save exit.
I boot the PC, Ez debug light for CPU comes on, anything I tried a day before doesn't work now. Someone please help!
My specs are:
Ryzen 5 3600
MSI B450M PRO VDH PLUS
Corsair Vengeance LPX 3200MHZ
MSI Radeon RX 5700 Gaming X
Silverstone 550W ET550B
Btw, every time I tried to change the RAM speed to the advertised speed, it always did this, but this time it just won't let me boot anymore.
 

flaminggamer659

Prominent
Dec 5, 2018
17
1
515
0
It works miraculously now, except the RAM speed is at 2133mhz instead of 3200.
This problem always happens when I load up the XMP profile of the advertised 3200mhz. Is it normal for it to start off lower than it should?
 

flaminggamer659

Prominent
Dec 5, 2018
17
1
515
0
This MSI board has the EZ Debug LEDs. The CPU and DRAM ... Probably the motherboard if you are getting an error light for the ram that you know works. I would just contact ... A lot of times, you need a new BIOS to work with a new CPU.
Alright then, I'll give it a shot, but the mobo I bought said Ryzen 3000 series ready. But anything that can help my PC I'll take.
 
Last edited by a moderator:

flaminggamer659

Prominent
Dec 5, 2018
17
1
515
0
UPDATE:
My PC works better now with new bios, RAM problem still persists, and CSGO won't work. Is there any way for the RAM to go up to it's advertised 3200mhz? Every time I try, it repeats the same EzDebug LED thing scenario.
 

ASK THE COMMUNITY

TRENDING THREADS