Question MSI GL 63 9SD laptop windows 10 digital signature makes built-in keyboard not work???

notinflight

Prominent
Jun 2, 2019
3
1
515
0
My laptop is an MSI GL 63 9SD
EDIT: I also recently upgraded the NVME Hard drive (primary) to a 1 TB Samsung EVO and upgraded the RAM with some crucial RAM

So recently Windows did some updating and now the digital signatures of my laptop's built-in keyboard and mouse trackpad are not valid for some reason.
I figured out how to restart the laptop to the troubleshoting screen and can disable digital signature requirements but this has to be done every time
I restart the laptop now in order for the keyboard and trackpad to work.
I have an external Razer keyboard and an external ANKER USB dongle/wireless mouse and the Razer doesn't work either. It says the digital signature is invalid.
However what is WEIRD is that the USB dongle/wireless mouse works when the built-in keyboard and trackpad and the Razer won't.

Anyway.

I did some digging and it looks like I need to disable the secure boot from my BIOS and then run command as admin and run the bsdedit/ settestsigning on command in order
to permanently disable secure boot so that I can run drivers without digital signatures.

My problem is that when I go onto my BIOS I have 3 options

  1. Run UEFI
  2. Run UEFI with CSM
  3. Run legacy
The secure boot function is located in the security tab of my BIOS and it says something along the lines of
"Secure boot is enabled when Keypass is activated, mode is User/deployed, and CSM is disabled.

So I can't turn it off from UEFI at all.
When I run it as UEFI with CSM I can't turn it off either.
When I run as legacy it disables the secure boot BUT my windows boot option is missing from
the boot order processes and there is no option to ADD a boot method, all I have are: USB CD DVD, and 3 others that I don't recall atm but
none of them were my primary drive with windows installed. Weird.
I tried running legacy to see what would happen and on restart I got a black screen with white type that scrolled saying something about it could not boot
and then something about PXE or something not detected.

IDK

I had initially tried uninstalling and reinstalling all my keyboard drivers etc and that didn't work. I also tried uninstalling the recent updates. That didn't work.

I've never held windows in high regard, but this is a new low.
I'm seriously considering making the leap to Linux and just running all my programs in WINE after this because
this is super frustrating.

IF I manage to get the secure boot disabled I've still got a gaping hole in my system security only so that I can
USE MY FREAKIN BUILT-IN KEYBOARD AND MOUSE! Like what the 'H' Microsoft?

Anyway.
Does anyone have any idea how to fix this issue?
Any help would be greatly appreciated!!!!!
 

ASK THE COMMUNITY

TRENDING THREADS