Question MSI GT70 cannot install windows (tried few)

Jan 22, 2018
Hello, okay so my issue is that I can't seem to install windows 10 normally on my MSI GT70 laptop. First setup I had in USB made my pc shutdown right on the purple setup screen. Another was in other USB made with another tool (older win10 iso) and it ran install. After reboot it couldn't finish installing the windows, because it shut down at (setting up devices). Tried many times again, other internal Drive and so on. Same results. Tried third installation from the first USB and the same result as previous: pc shuts down as soon as "setting up devices appears". Tried removing ram sticks (not all 4 yet). To me sounds like a hardware problem.

Now a little back story: So I tried to install the windows when my forst windwos 10 was unusible. Search bar couldn't find anything. I treid many fixes. Also tried resetting windows and that shut down my ppc at some point and notified me that it failed to do the reset and the error showed no code. At the end I thought that fresh windwos might be a good idea. Also I had an upgrade of laptop before installing new windwos. Nothing seemed to be worse or better after that. Then I just reinstalled windows and now the pc is completely unusible. Also one fun fact: wiindwos only allow me to install when RAID mode is enabled, my drives are not in raid mode and never were.

The last time windows were working perfectly was when I used it with same ssd but HDD inserted... Weird...

What I tried:

Removing GPU (MXM)

Removing drives and also tried different ones.

Removing Dvd Drive.

Removing some of the ram (2/4 sticks)

I suspect hardware or bios corruption. But bios corruption is invalid argument, because on both MOBOs same shut downs and problems appeared.
Last edited by a moderator: