Question MSI laptop is stuck on booting into EFI Shell after Windows 10 update ?

May 17, 2021
3
0
10
0
Running Windows 10 on MSI GF65 Thin 9SD

After recent windows update which included a security update, my laptop now boots to the EFI shell instead of direct to Windows. Exit command in shell then boots to Windows.
After numerous searches, I have reset the BIOS to original settings. Under the boot settings in BIOS, I have tried, Legacy boot, UEFI boot, and UEFI with CSM Boot (these are my only options). Each of those were tried with and without Fast Boot enabled. I have changed the device boot order making sure Windows boots first in all cases and removed all USB peripherals. On at least one occasion while messing with settings I had a "Boot Security Violation" as well.

Once out of EFI, Windows seems to run normally, without any issues. Laptop is a little over a year old and the only issues I've had are a little overheating when under load from gaming.

Would appreciate any insight on how to get this thing back to booting straight to Windows. Thanks!
 

ASK THE COMMUNITY

TRENDING THREADS