Question MSI Laptop not even booting to BIOS

NixPardus15

Reputable
Jun 19, 2015
3
0
4,510
0
Hello,

Hope the community can help answer some questions about repairing or at least recovering from my laptop. I have an MSI Stealth GS70 2QE 097 (https://www.google.com/amp/s/m.newegg.com/amp/products/N82E16834152682). I was using my laptop just a few days ago studying. I was finished so I closed the lid and took it upstairs. I had "closing the lid" set to hibernate on windows OS, not sure if that is important. About 20 minutes later I tried to boot and the computer would not even get to BIOS. It would just power up, display the MSI logo on screen, and the CPU fan would spin up. There are no text prompts, only a black screen with a white MSI logo in the middle. I tried holding down every key upon start and it would not do anything. I let it sit trying to boot for about 20 minutes and it only got warm and then I turned it off.

To give some more context, I have owned this laptop for 3.5 years. I sent it to MSI on an RMA about 1.5 years ago as the OS stopped recognizing the dedicated graphics card in the machine (may have been because of overheating). MSI said they replaced the motherboard. I also had some keys on the keyboard stop working, the mouse was double clicking and the battery life was 30 minutes so they replaced both of those too. The computer case came back in a different color from the original (grey instead of red) So I am not entirely sure if they just replaced the motherboard, or if they just moved my SSDs and HDD over to all new internals. About a year later, upon boot the message would display "no media present" but it would always boot to windows so I didn't think anything of it and everything worked just fine so I moved on.

To troubleshoot my current issue, I first tried removing the battery and power and holding the power button for 60 seconds and then booting, same issue. I have two sticks of 8 GB ram and tried reseating the RAM. Tried only one stick on each port with each stick. Still the same issue. Tried reseating the CMOS battery, wouldnt turn on after that. Replaced the CMOS battery and was back at square one. Took it into MicroCenter, they tried to boot to an external linux mint flash drive, the MSI logo would appear and then when holding delete the screen would go blank except for a small white rectangle off center from the screen, but nothing beyond that. The computer doesn't make any sounds, but it never has.

Is there anything else I can try? I think it's a motherboard problem but I'm not an expert. Do you have any hints of what part might need to be replaced? If its beyond repair or too expensive, is there a chance I can recover the data from the SSDs? There are three m.2 on RAID 0 or 2 (there are two partitions for the three drives so I'm not sure which RAID it is), but I was not sure if it is possible to recover the data without the same raid controller. I'm not super invested in the data on the drive, as it's mostly just assignments and essays, so I'm not looking to hire a data forensics company to recover my data, I just thought it would be nice. I appreciate any help!
 
Feb 16, 2019
6
0
10
0
I did some practices last year of my studies were we did a raid 0 and then took one drive out to see if the data was gone or corrupted after plugin in the disk again to the computer, the data was good so i think u could recover ur data just by pluging in the disks in another pc and mounting them into the same raid config that u had before, im not sure at all but im almost sure of it.
 

Similar threads


ASK THE COMMUNITY