Question MSI MAG B550M MORTAR WIFI no audio output

tibo.tuypens

Reputable
Sep 9, 2017
9
0
4,520
1
Hi internet people,

I just completed my Ryzen 5 - 5600x build just to find out that none of my audio works.
So the motherboard (MSI MAG B550M Mortar WIFI) has the follow IO:


None of the regular audio jacks seem to detect when I plug my speakers in (or any other audio device). The speakers being Logitech z333. They worked fine before on my MSI Mortar Arctic motherboard..
The speakers also work fine when connected to my laptop or phone..

Only the optical out port seems to be detected as 'connected' in Windows 10. Seen by the green audio bars moving. The others are marked with the RED arrow as 'not connected'.
Speakers are not showing up in device manager
I have tried multiple versions of Realtek audio drivers, I have tried multiple bios versions.. Cleared the CMOS.. Nothing seems to get them to work.
Front IO audio also does not seem to respond when connected. The only audio available to me is via usb headphones or crappy monitor over hdmi audio..

I am in contact with MSI support but I haven't gotten any tips besides clearing CMOS (so far).
If anyone has any idea's, I'd really appreciate the help.
 
Last edited:
Apr 22, 2021
1
0
10
0
MSI have created a <Mod Edit> actually. I face the same exact issues. I purchased this motherboard and AMD Ryzen 5600x and my speaker or sound card doesn't detect. If anyone find any solution please let me know.

Windows is updated to latest version, all drivers are updated.
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS