• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question MSI MPG X570 GAMING EDGE WIFI - Black Screen

Jun 20, 2020
4
0
10
0
Hi,

I turned my pc on today and nothing happened for a minute and then the MSI EDGE logo showed up with the text "preparing automatic repair". It wasn't doing anything for a while so i turned of the pc and restarted it and now I have no visual! I am really stressed and need some help!

Everything visually still works. I can see all the fans work all the ram the gpu my mouse is still lit up and keyboard. I just get a black screen and it says that I have no display input on my monitor. So the only this is that I have no visual... The motherboard EZ DEBUG doesnt have anything lit up, which indicates that all the CPU / GPU / VRAM / BOOT are all still working.

Please help. I am considering doing a Flash of my BIOS with the flash button on the back and a formatted usb with the latest bios on it (as the manual says) but I wanted to see what others thought before i do this.

Thanks
 
Jun 20, 2020
4
0
10
0
Hardware:


CPU: AMD Ryzen 7 3800X
AIO: NZXT Kraken X73 360mm
PSU: Seasonic FOCUS GX-850
MOBO: MSI MPG X570
GPU: MSI GeForce RTX 2080 Super
RAM: Corsair Vengeance RGB PRO 32GB
M.2: Kingston A2000
SSD: Samsung 860 QVO 1 TB SATA
HDD: Seagate 2 TB BarraCuda
 

ASK THE COMMUNITY

TRENDING THREADS