Question MSI MS-7681 won't boot from flash drive... ideas?

jhsachs

Distinguished
Apr 10, 2009
217
6
18,685
0
I'm trying to build a system with a salvaged MSI MS-7681 motherboard, condition unknown. The board POSTs successfully, but when I try to boot from a flash drive in order to install an operating sytem it goes straight to the EFI monitor, as if no device were available.

I've tried two different flash drives. One was freshly loaded with the Windows 10 image, the is loaded with an Ubuntu image and has been used successfully on other systems. I got the same result with each.

Boot priority 1 is "USB key." (I assume "USB key" means a flash drive, since I don't see a more appropriate option on the menu). Boot priority 2 is "hard drive," but since I can't get the board to boot at all I haven't attached a drive yet.

I know the USB port is working because when I tried to boot from a flash drive that was not in UEFI disk format, the motherboard knew it; it displayed a different message, "insert a valid drive and press any key."

Have I missed something here... some other setting I must change to boot from a flash drive? If not, should I just conclude that this board is defective and discard it?
 
I'm trying to build a system with a salvaged MSI MS-7681 motherboard, condition unknown. The board POSTs successfully, but when I try to boot from a flash drive in order to install an operating sytem it goes straight to the EFI monitor, as if no device were available.

I've tried two different flash drives. One was freshly loaded with the Windows 10 image, the is loaded with an Ubuntu image and has been used successfully on other systems. I got the same result with each.

Boot priority 1 is "USB key." (I assume "USB key" means a flash drive, since I don't see a more appropriate option on the menu). Boot priority 2 is "hard drive," but since I can't get the board to boot at all I haven't attached a drive yet.

I know the USB port is working because when I tried to boot from a flash drive that was not in UEFI disk format, the motherboard knew it; it displayed a different message, "insert a valid drive and press any key."

Have I missed something here... some other setting I must change to boot from a flash drive? If not, should I just conclude that this board is defective and discard it?
which MS-7681 is your board? this could refer to some msi P67 and Z68 boards
 

ASK THE COMMUNITY