MSI P6N Diamond and 1066mhz Ram BSOD


Dec 15, 2005
I have a customer who purchased an MSI P6N Diamond motherboard and 4gb of OCZ SLI 1066 Ram. He is running Vista 64 premium (and has tried XP as well). Whenever he sets his Ram to run at 1066, he gets frequent BSOD's. When it's clocked back to 800mhz, it runs fine. It does this in Vista and in XP. He says he called MSI and they immediatley told him to RMA....he's already returned 2 sticks of the ram and has received replacements. Aside from obvious settings in the BIOS, does anyone out there have any ideas?
Thanks in advance.


Jan 2, 2007
I've had a "not so different" issue with the P6N Diamond. I can run the system with 2GB and no problems, but if I add 2 GB more (4GB total), I cannot boot into Vista 64-bit or XP and all memory tests I run fail. I've tried the native Vista memory test and the three memory tests on the Hiren's Boot CD. Also, before someone asks the obvious, yes I have tested each memory module individually and yes each module is good. I can actually install up to 3 modules, but not 4. I've read more than I care to about the install issues with Vista and 4GB, but even fully installed I can't get things to work so I'm stuck with 2GB :(

If anyone reads this and has any suggestions I'm all ears. I've worked with MSI and they couldn't explain why I'm having problems and has given up and said I'll have to work with Microsoft since the MB passes POST. I guess it doesn't matter to them that I cannot run even a non-MS OS.



May 21, 2004
If it's 1066 RAM, it's almost guaranteed it's rated for higher than the 1.8 volt JEDEC standard. He needs to make sure in the bios he ups the ram voltage to whatever OCZ recommends. All OCZ 1066 RAM on the Egg is rated for either 2.1 or 2.3


Jun 4, 2007
I have a P6N diamond and was recently having problems with my ram as well.

I have 4 1GB sticks of Cruicial Ballistix ram - DDR 800. I could only get 3 sticks to work, no matter what order I tried. I almost RMA'd the board, but decided to continue to mess with it.

Make sure you update the BIOS - the most recent revision came out only a few weeks ago and solved the issue for me. It should be revision 1.2.

For me, it was an issue of not having a floppy. I borrowed a USB floppy and followed the basic update procedure, plugged in all 4 sticks, and no problem.

The board should not have a problem with the voltages, I believe. It's default is auto between 1.8 and 2.8, so It should do what it needs to run. *The Crucial Ballistix are recommended at 2.2, I believe). You can set it manually, but try to update the BIOS and see if that helps.

Good luck.