Question MSI Raider Ge75 - add a new SSD and the old one "disappear"

Dec 2, 2021
2
0
10
0
Hello i have a MSI raider GE75 and i wanted to add an SSD NVME P5 crucial (M2 2280) and i got a strange problem :

If i add the P5 SSD the original system SSD (250go) "disappear" i'm just stuck in bios and it show me : the P5 (empty) and the HDD (original)
If i pull off the P5 ; the original SSD is working and windows launch normally

I tried to swap the slot of the two SSD : the original SSD (250Go) is still nowhere when the P5 is present

is there any way that the P5 can work with the original SSD of the msi raider ? or two NVME can't coexist ?
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

You might want to see if your laptop has any BIOS updates pending. If you have a number of BIOS version to work through to the latest, gradually work your way to the latest as opposed to jumping to the latest. Also, have you tried removing the HDD after you've populated the Crucial SSD in the laptop? What capacity is the Crucial drive?

+ From this drop down list;
https://us.msi.com/Laptop/GE75-Raider-10SX/support
which one do you have?
 
Dec 2, 2021
2
0
10
0
Welcome to the forums, newcomer!

You might want to see if your laptop has any BIOS updates pending. If you have a number of BIOS version to work through to the latest, gradually work your way to the latest as opposed to jumping to the latest. Also, have you tried removing the HDD after you've populated the Crucial SSD in the laptop? What capacity is the Crucial drive?

+ From this drop down list;
https://us.msi.com/Laptop/GE75-Raider-10SX/support
which one do you have?
Thks for your answer i misspell i have : a GE73 Raider RGB 8RF (030XFR)
The Crucial drive is an : Crucial CT1000P5SSD8 SSD Internal P5 1To (3D NAND, NVMe, PCIe, M.2, 2280SS)

I didn't try to remove the HDD didn't see any relation will try it also
Didn't update my bios will do it asap (always scare to do it)
 

ASK THE COMMUNITY

TRENDING THREADS