[SOLVED] MSI RTX 3070TI Gaming Trio no display

tdpark

Reputable
Jun 21, 2017
14
0
4,520
1
I received my graphics card MSI RTX 3070TI Gaming Trio last week, installed it fine, and works fine for a week.
This morning I was still using it before I shut it down normally, and now the PC can't detect this graphics card. I didn't change any graphics setting before I shut down.
My motherboard MSI EZ debug white light (VGA) is on, but my graphics card fan is running, RGB also on, but display not working.

I reinstalled it and reset the CMOS, still can't detect it.
Now I don't know if I installed it correctly, I plugged in 2*8 pin PCIE cable. Also, I don't know if I installed the support bracket correctly.
Please help

This is my setup:

CPU: AMD Ryzen 7 5800X 3.8 GHz 8-Core Processor
CPU Cooler: Noctua NH-D15 CHROMAX.BLACK 82.52 CFM CPU Cooler
Motherboard: MSI MAG X570 TOMAHAWK WIFI ATX AM4 Motherboard
Memory: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3600 CL18 Memory
Storage: ADATA XPG SX8200 Pro 1 TB M.2-2280 NVME Solid State Drive
Video Card: MSI GeForce RTX 3070 Ti 8 GB GAMING X TRIO Video Card
Case: Lian Li Lancool II Mesh ATX Mid Tower Case
Power Supply: SeaSonic FOCUS 750 W 80+ Gold Certified Fully Modular ATX Power Supply
 

tdpark

Reputable
Jun 21, 2017
14
0
4,520
1
  • Deleted by tdpark
  • Reason: Problem happened again
Well, my graphics card is working again, after not using it for a week. No RMA

I am guessing S.A.M. (resize bar) has a conflict between the motherboard and the GPU because I turned off resize bar last week.
Hope this information will help.
 

hadiahmed29

Reputable
Feb 23, 2018
183
17
4,615
6
Have you tried a different port ?
Are you using HDMI or Display port for the card ?
Also is there a constant VGA white light on your motherboard?
Because that usually means that there is a problem in the GPU or display if there is no display
 

tdpark

Reputable
Jun 21, 2017
14
0
4,520
1
Have you tried a different port ?
Are you using HDMI or Display port for the card ?
Also is there a constant VGA white light on your motherboard?
Because that usually means that there is a problem in the GPU or display if there is no display
Dont think its the display issue or HDMI issue.
I install the graphics card on different computer, and same issue, other computer motherboard also show white light on VGA.
 

hadiahmed29

Reputable
Feb 23, 2018
183
17
4,615
6
Dont think its the display issue or HDMI issue.
I install the graphics card on different computer, and same issue, other computer motherboard also show white light on VGA.
Seems there is a problem with the GPU then not sure but i would still recommend that you should change the cable or switch between the DP and HDMI as i had the same issue but my display was on and changing the cables fixed it.

But you can check these links for further investigation and a possible fix

View: https://www.youtube.com/watch?v=OZL9INhdQ2I

 

ASK THE COMMUNITY