[SOLVED] MSI RX 470 Armor OC Editions fans not spinning.

Jun 4, 2019
9
0
20
2
Hi guys, need some advise.

A friend of mine is selling his MSI RX 470 4GB Armor OC Edition for roughly $40. Problem is he said that the fans are no longer spinning. The GPU works, drivers can be installed, he can game. MSI Afterburner does not detect the fans. No graph on the tachometer even after setting the fans to 100% manually they don't spin. I have a set of twin frozr fan from a dead GTX 750ti and I am thinking of buying the card and replacing the fans with the frozr one's. Would it be a good deal? What do you guys think? is the problem with the gpu board or only the fans?

Here are some photos:













Thanks!
 

boju

Champion
First remove the gpu fan and check the cable is connected to the fan header on the gpu's pcb (same way as you would connect a cpu fan). It could have come off. There's no guarantee your fans will work if don't know why the 470's fan's aren't working.
 
Jun 4, 2019
9
0
20
2
First remove the gpu fan and check the cable is connected to the fan header on the gpu's pcb (same way as you would connect a cpu fan). It could have come off. There's no guarantee your fans will work if don't know why the 470's fan's aren't working.

Thanks for replying,

He said that he already checked that and the GPU fan cable is properly attached. He also mentioned that this suddenly happened. the fans just stopped spinning altogether one day while gaming. He lives far away and has work so we do not have time to test. If I purchase it that would be it.
 

boju

Champion
If it was me with the card i would have just gave it to you.

Anyhow if you're lucky it's just the fans and not the controller. Bit of a coincidence both fans going though so that puts some doubt the problem being just the fans.
 
Jun 4, 2019
9
0
20
2
If it was me with the card i would have just gave it to you.

Anyhow if you're lucky it's just the fans and not the controller. Bit of a coincidence both fans going though so that puts some doubt the problem being just the fans.
That's what I was thinking as well. Thats the very reason I am hesitating to grab the card.
 
Jun 4, 2019
9
0
20
2
Update.

So I ended up getting the card. Couldn't pass on a potentially good deal.

Tried a set of fans from my dead gpu and they worked flawlessly. Cleaned the card, replaced thermal paste. Tested and it was working like new. looks like new as well after clean up. temps are good. Good buy as it turned out.
 

ASK THE COMMUNITY

TRENDING THREADS