• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question MSI RX5700 XT - 60% Usage

Nov 2, 2019
7
0
10
0
Hello,



I just bought a Custom RX5700 XT.



Running the first games, i noticed that i wasn't having much greater performance then my older GPU ( gtx 1050ti oc )



I then noticed that GPU usage wasn't getting higher then mid 60 % .



When checking the cpu, im geting around 80% usage in pubg and 90% in BF5.



Can someone help me out?



System Specs:



i5 8600K OC to 4.5

3x4gb (already tried only two channels/sticks, no change)

MB : z370p d3
 

AshMetalRaf

Prominent
Sep 19, 2018
127
21
615
6
Hello!

It's mostly due to CPU bottleneck though with i5 8600K you shouldn't get that issue..odd.
Try updating your graphics card and make sure your power plan set to High Performance.
My XFX RX580 8GB does the same, I have managed to get the GPU to 99% by going to AMD radeon settings, head to Display and turn on Virtual Super Resolution.
Once that is enabled, go to your desktop, right click and Display settings. You'll notice you have 2k resolution or higher now, select highest one and run any game, make sure you select the same resolution within the game as well.
 
Nov 2, 2019
7
0
10
0
Hello!

It's mostly due to CPU bottleneck though with i5 8600K you shouldn't get that issue..odd.
Try updating your graphics card and make sure your power plan set to High Performance.
My XFX RX580 8GB does the same, I have managed to get the GPU to 99% by going to AMD radeon settings, head to Display and turn on Virtual Super Resolution.
Once that is enabled, go to your desktop, right click and Display settings. You'll notice you have 2k resolution or higher now, select highest one and run any game, make sure you select the same resolution within the game as well.

Hey there,
thank you for the reply

i've tried VSR, but no success.

Im running out of ideas. i might take the computer to some tech guy, but i was trying to fix it myself
 
Nov 2, 2019
7
0
10
0
So, earlier today i got 61% in the userbenchmark.

I just re installed amd drivers (clean install)

I'm now scoring 98%.

even with this great result, i open PUBG and i get 60% usage.

I'm so confused.
 

AshMetalRaf

Prominent
Sep 19, 2018
127
21
615
6
So, earlier today i got 61% in the userbenchmark.

I just re installed amd drivers (clean install)

I'm now scoring 98%.

even with this great result, i open PUBG and i get 60% usage.

I'm so confused.
It seems like we are bound by lack of stability in games fps and gpu/cpu usage wise. clearly it's not always your PC is the culprit as these issues were occurred on older and newer machines as well. something is unstable either the fault belongs to the game's engine limiting the usage on certain build or incompatible things need to be patched by the developers or rather Microsoft. We are just gonna have to adapt to the usage bouncing around and hope for a fix to all these annoying problems.

Sorry that i couldn't be much of a help
 
Nov 2, 2019
7
0
10
0
It seems like we are bound by lack of stability in games fps and gpu/cpu usage wise. clearly it's not always your PC is the culprit as these issues were occurred on older and newer machines as well. something is unstable either the fault belongs to the game's engine limiting the usage on certain build or incompatible things need to be patched by the developers or rather Microsoft. We are just gonna have to adapt to the usage bouncing around and hope for a fix to all these annoying problems.

Sorry that i couldn't be much of a help

Hello, i finally solved the issue.

Turns out the problem was the ram.

I had really slow ram, wich i totally forgot about - > 2400 cl 17


got some juicy Hyperx 3200mhz cl16 , and cpu and gpu are working perfectly together.

Hope this post finds someone in need.

Thank you
 

ASK THE COMMUNITY

TRENDING THREADS