Question MSI X370 Gaming plus won't recognize any ethernet lan cable!

Nov 26, 2019
3
0
10
0
Hey,
I've got my motherboard 2 or 3 months ago and I couldn't get my PC to connect to my router through an ethernet lan port I was using a WiFi dongle till today! but now I got a new router which only supports ethernet and I don't know what to do! I've tried installing the drivers but it gives me this error
I would really appreciate any help I can get
 
No it doesn't show up in device manager.
Already checked it and it is enabled.
No nothing is blinking!
Have you checked that the Realtek Ethernet NIC is enabled in BIOS?

If it's enabled, nothing works and neither of the LED lights on the ethernet port jack flash with a known-good cable inserted and connected back to a known-good router then the ethernet port could simply be dead. Happened to me on an Asus motherboard.

Easy fix: get an ethernet add-in card to go in one of your unused PCIe slots.

You do have one, I hope?
 
Last edited:

shivababbli

Reputable
Apr 16, 2015
665
3
5,165
67
Hey,
I've got my motherboard 2 or 3 months ago and I couldn't get my PC to connect to my router through an ethernet lan port I was using a WiFi dongle till today! but now I got a new router which only supports ethernet and I don't know what to do! I've tried installing the drivers but it gives me this error
I would really appreciate any help I can get
Try to use a bootable Ubuntu or any other OS and check if it's a problem of your OS
 

ASK THE COMMUNITY

TRENDING THREADS