MSI X399 MEG Creation BIOS very slow and long boot

indu111

Honorable
Dec 23, 2012
6
0
10,510
0
Hello!
I just finished building my Threadripper 2950x build. I seem to have an issue with the BIOS taking forever to POST. After a cold boot, BIOS takes over 2 minutes to boot and usually hangs in code 92 for the longest time followed by A2 being the next longest wait time. I read that 92 is PCI Bus initialization has started and A2 is IDE Detect. Not sure how this information helps as I already have spent hours reading forums everywhere about people facing slow boot times because of these codes but nothing worked.

Anyways eventually it hits code 0d and boots. From that point, Windows loads within 5 seconds and I am immediately on my login screen and everything is stable. Desktop runs stable and windows 10 event viewer shows no critical errors. From within windows if I soft restart or shutdown and power on immediately, BIOS boots right away and I am on my login screen within 10-15 seconds. Its just this issue with cold boot especially I feel it is time based I think. The longer it stays turned off the higher the chance it would boot slow. I come home from work every night and it always takes atleast 2 minutes to boot.

Please do kindly help as I don't know whether to RMA the board or this is fixable.

My system specs (everything running stock no OC other than RAM running at AMP/XMP profile):

CPU : Threadripper 2950x
Motherboard: MSI x399 MEG Creation
Ram: GSkill F4 3200C14Q-32GTZRX (their ryzen threadripper compatible kit), I only have installed one stick in slot B2 (furthest right from cpu)
GPU: Nvidia GTX 960 (temp card from a friend planning on getting a newer RTX card)
Storage: Single M.2 Samsung 970 Pro 512 gb
PSU: EVGA 1000w P2
Monitor: Asus Rog ultrawide PG348Q
BIOS: 1.20
OS: Windows 10 Education 64 bit Version 1809 (OS Build 17763.194)

Please let me know if you need any more information.
I have already tried the following:
- Changed single RAM stick to another slot
- Changed GPU to another 16x slot
- Changed m.2 nvme to another slot
- Held Clear CMOS button in the I/O panel and then updated bios to 1.20 using MFlash
- ran chkdsk and windows disk optimization on the m.2
- booted with no USB device connected other than keyboard mouse and thermaltake fan controller on the internal usb 2.0 port (ethernet jack and MSI's wifi antenna is also connected)
 

Similar threads


ASK THE COMMUNITY