Question MSI X470 Gaming Pro - Memory Issues?

jerreece

Splendid
I just received a brand new MSI X470 Gaming Pro motherboard, AMD 2600X CPU, and Corsair LPX Vengeance DDR4 (CMK16GX4M2B3200C16) today.

I'm going to build a system for my kids.

Anyhow, I removed an Asrock x370, AMD 1600, with Corsair LPX Vengeance DDR4 from my tower. I then installed the above components in my tower. All over components remained the same (850W PSU, XFX 5700XT GPU, hard drives, etc).

The motherboard, and Windows, don't always recognize all 16GB of RAM. It's odd. The board came with a Bios from Jan 2019 installed. The system booted up with 7.9GB of Total RAM. The BIOS does not allow for settings for memory mapping that I can find. So I swapped the DDR4 DIMMS around. Suddenly I now have 16GB. Tried playing an existing install of Red Dead Redemption 2 (obviously I installed all the lastest drivers from MSI's site, updated my GPU driver to the latest, etc). I can play for about 2 minutes and the game crashes. So I tried another working game. It crashes 2 minutes in as well.

So I took the Corsair DDR4 3000 dimms out of my other motherboard. Put those in this new system. Same issues with the BIOS not always seeing 16GB.

It seems if I set the BIOS to "default settings" it only sees 8GB of RAM. But if I select an XMP profile or manually set frequency it then sees all 16GB. (Default sets RAM at 2133MHZ).

Windows has blue screened on me a few times giving Stop Code: "Memory Management" and "IRQL Less than or Equal".

I've updated to the latest E1 BIOS from MSI. Doesn't fix the issue. So I downgraded to the D1 BIOS. Doesn't fix it either.

Bought the parts through Amazon. So I can probably send them back if need be. But I've never run into an issue like this before. Not sure what else to check.
 

boju

Champion
maybe standoff related like this thread?

 

jerreece

Splendid
maybe standoff related like this thread?

Bizarre. I did see the stand-off warnings on the back of the board before I installed it. Thought that was fairly odd. But I'm pretty sure I do not have any additional standoffs behind it (ATX only).

I suppose I can tear it open and remove the board again just to be sure though.
 

jerreece

Splendid
maybe standoff related like this thread?

Just pulled the motherboard out entirely. There are no extraneous stand-offs behind the board.

When I put the board in I only have an 8pin CPU power cable. I found a 4pin stuffed in the case. The motherboard has an 8pin & 4pin CPU power connector. So they're both plugged in now. From what I've seen online both shouldn't be needed unless I want to OC.

Anyhow. I rebooted the system. Still shows 8GB of RAM installed in the BIOS and Windows. So I rebooted and went into the BIOS again. Selected XMP Profile 1 (2933MHZ). It instantly shows 16GB of RAM in the BIOS without having to reboot. Literally changing from Default (which auto sets 2133MHZ) to XMP 1 (2933MHZ) changes the BIOS reading from 8GB to 16GB.

Makes no damn sense.
 

jerreece

Splendid
Which dimm slots are you using?

When you tried adjusting ram manually, did you set primary timings and dram voltage to 1.35v?

Did you clear cmos and load optimised defaults after bios flash?
The board itself, and the manual, say to use Slots 2 & 4 first. So obviously I started there. Also tried slots 1 & 3 but that was no different.

That said - now that I've got the 8pin and 4pin CPU power connectors... I just played Red Dead Redemption 2 for an hour without a hitch.

So apparently you DO have to connect both CPU power connectors after all. Still doesn't explain why the BIOS only recognizes 8GB when using default settings.
 

ASK THE COMMUNITY

TRENDING THREADS