Question MSI x570 Gaming Plus suddenly won't boot/post

d2h

Jan 5, 2022
2
0
10
0
First off, thank you to anyone that takes the time to read this.

My gaming machine (specs below) suddenly stopped booting. It worked fine the night before and in the morning it wouldn't POST. The CPU LED stays lit. GPU & RAM tested in another system.

Here's where it gets interesting, at least to me. The PC will boot with a 1700x and a 2700x, it will not boot with a 3900x or a different 5900x.

The BIOS has been reflashed to the most current non beta version, still no POST/CPU LED lit on mobo.

I've tried booting with only 1 RAM stick and in the chance that one was faulty, tried with the other 3 sticks in A2 one at a time.

Someone suggested it could be the PSU, so that was replaced with a Corsair 850watt. Still no POST.

Every attempt has been made with only mouse & keyboard connected with USB, nothing else aside from monitor.

IMO, the only other thing it could be is the mobo, right? What am I missing here?

MSI X570 Gaming Plus
Ryzen 9 5900x
32GB G.Skill Trident Z 3200
Zotac Trinity 3080
WD 1tb NVME
EVGA 750w PSU (now Corsair 850w)
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Something tells me that the BIOS got corrupt or that the processor itself has an issue.

Have you tried dropping the processor into a known working board(one that has seen a Ryzen 5900x in use on it)? If so, then you can chalk the issue up to the board being the problem. As for your PSU's, Corsair and EVGA are the brands of said PSU's while 750W and 850W are the advertised wattage's, can you please specify the model for the units. As for the EVGA unit, how old is it, considering the Corsair is brand new?

Just for the sake of relevance, can you state what BIOS version you're on for your motherboard at this moment of time? Is this the motherboard that you're working with?

Greg Salazar had a video on his YT channel whereby a Ryzen processor's memory controller was the issue all along and not the rams since one channel was working while the other channel was giving a no POST scenario.
 
Reactions: d2h

d2h

Jan 5, 2022
2
0
10
0
Thank you for your reply. The CPU (original 5900x and the replacement I foolishly ordered) does boot in another system.

My BIOS version is 7C37vAF which is the most current non beta. Prior to these issues I was on 7C37vAD from May.

I just realized the typo in my title. It's the Gaming Plus not Pro found here

All the hardware in this build is just over a year old. Most of it was bought in October and November of 2020 with the GPU being bought in January.

The Corsair PSU is the RM850x.

"Greg Salazar had a video on his YT channel whereby a Ryzen processor's memory controller was the issue all along and not the rams since one channel was working while the other channel was giving a no POST scenario. " Is it possible this would allow the PC to boot with the other Ryzen processors I listed in the OP but not the 3900x and 5900x?
 

mollycule

Distinguished
Jan 28, 2014
14
0
18,510
0
I'm having a similar issue -- except with some fascinating (and annoying) twists.
I installed the Ryzen 9 5900x in my system (MSI X570 Gaming Plus) last week. The mobo was making one long beep and two short beeps, meaning a graphics issue, but then would go on to boot to Windows just fine. However, I was unable to access the BIOS at all. I used the Flash BIOS feature to update the BIOS, and I even tried rolling back a few versions, but no dice.

Then today, I bought a new case and transferred everything over. New PSU, but nothing else. But now it won't boot at all -- still one long beep and two short beeps, but the EZ Debug light flips to Boot, indicating it's not detecting the boot drive. I tried all kinds of stuff -- unplugged every hard drive except for the Windows drive (an NVME in the CPU M.2 slot), triple-checked all power, RAM and graphics card connections, even dropped to one RAM stick. Same behavior every time.

So I decided to try putting my previous AMD Ryzen 7 3800x back in -- and bam, it got me to BIOS! Haven't tried fully booting yet, but it proves that nothing is wrong with my graphics card (NVIDIA GeForce GTX 1070), or my RAM, or the mobo. So I think something is whack with the processor, since it's supposed to be compatible with this motherboard. Going to seek an RMA, since few else on the internet seem to be having this problem.
 

ASK THE COMMUNITY