Question MSI Z390 Gaming Edge AC Intel Ethernet Adapter i219-v (Code 10)

gregc320

Reputable
Jul 19, 2016
3
0
4,510
0
Hi guys,

Having some trouble with my ethernet adapter on my computer. It was working fine up until about 3 days ago when all of a sudden stopped working - at first, it appeared to be connected to an "unidentified network" before completely disappearing from my list of adapters in network settings.

Now, in the device manager I have the caution triangle on the adapter and it's giving me a "Code 10 - device cannot start" the oem9.inf can't start, leading to the e1dexpress service not working??

I've tried the following;

  • Disabling and re-enable the controller
  • Reinstalling drivers
  • Downloading drivers from both intel website and MSI website
  • Power cycling my PC
  • Updated windows and BIOS to latest versions
  • Clean install of windows
A good point to note, my motherboard is only about a month old, I'm finding it hard ot believe that it is a hardware issue but I could be wrong.

I downloaded a 3rd party driver software and next to my ethernet adapter, it has the "repair" option. Also, in the I/O panel, the yellow light is on when the cable is in, which according to the manual means its linked, so the adapter has power going to it and is functional I'm assuming?? But I'm at a standstill here I'm completely clueless on what to do. I've tried pretty much all the Code 10 fixes online, nothing has worked.

Any help is appreciated.

Kind regards,
Greg
 
Jun 30, 2020
1
0
10
0
I’m glad I’m not the only one having this issue now. I have the z370e gaming and the past 2 days I have no Ethernet only WiFi. Like you I have the orange light and an unidentified network error and I have even wiped my windows bought a new m.2 and even a better router and this has not fixed a thing. I hope someone can help.
 

ASK THE COMMUNITY

TRENDING THREADS