[SOLVED] Multimonitor display issue/ Display will freeze when certain monitors/TV on or off

Jun 30, 2022
2
0
10
0
X570 AORUS ELITE WIFI
AMD Ryzen 9 5950X
AMD Radeon RX 5600 XT
32GB RAM
500GB m.2
Windows11

Display consists of 2 MSI 27in 144hz monitors plugged into display ports and a Vizio TV plugged into the HDMI port from the AMD Radeon RX 5600 XT.

The problem starts at the Windows sign in screen. Example 1- In this instance all 3 displays are ON. After starting the machine the windows sign in screen is displayed on MSI monitor1 and is ready to accept my log in credentials. I click any button on my keyboard/mouse and the displays go black as if no displays are connected at all. In this scenario I'm forced to hard restart. Example 2- TV is OFF and 2 MSI monitors are ON. System fires up no problems and I'm able to click buttons ect. Now if I turn the TV ON the displays flash on and off a couple of times before they all go black. Again I'm forced hard restart. I'v had this display set up for about a year now without any issues. Last week I upgraded to Windows 11, during that period I had no issues. Iv installed the AMD Adrenaline software to keep my GPU drivers updated, but beside that I'm stumped. Help me Tomshardware. Also It's prob worth mentioning sometimes during example 1 everything will work no problem, but If I turn the TV OFF system goes black again. Its as if the GPU is all of a sudden not compatible with my Vizio TV. WHY!
 
Jun 30, 2022
2
0
10
0
The problem seems to lie with the TV, try to disable (HDMI) CEC in the settings of the TV.
I connected the TV to the internet and ran the updates which seems to have stabilized everything. I also disabled CEC per your recommendation as a precaution. What exactly does this setting control? The tooltip on my TV says "Select enable to control CEC devices connected to HDMI". What's the difference?
 

ASK THE COMMUNITY

TRENDING THREADS