[SOLVED] Multiple bsod errors on new pc

Jan 31, 2020
1
0
10
0
I just finished this build last week. My specs are an AMD Ryzen 7 2700x, G.Skill Ripjaw DDR4 RAM 16 GB, seagate 2TB HDD, Asrock b450 mobo, GeForce 1060 3b and an EVGA 750w bronze PSU.

I've gotten multiple different errors including memory management, kernal security and 2 others. I've ran diagnostics on the RAM and HDD and no errors came back. I've ran an SFC scan and no errors were reported. I've went through and updated my windows and all my drivers, issue still persists. I've disabled USB 3.0, issue still persists. I've monitored my temps, nothing out of the ordinary. I've changed my power plan settings to a few different options, issue still remains. I'm exhausting all my options and it seems that I cannot pinpoint what is causing this. At this point, the only thing I've not tried is completely reinstalling windows fresh... However, it's a pain going through and reinstalling everything all over again so I figured I'd ask here first and see if anyone has any suggestions. The bsod happens at random, however, it has NEVER occurred while gaming. It only seems to happen when I'm idly browsing the web. I've had bsod in the past and the issue was usually somewhat simple to pinpoint, this time however, I'm stumped.

I will say that I made an error in judgement and installed the drivers from the disc AFTER installing widows drivers and such. I understand that generally you should install the drivers from your disc first before installing any other. Possible that this caused the issue as well, however, I wouldn't think that it would.
 
Last edited:

PC Tailor

Judicious
Ambassador

PC Tailor

Judicious
Ambassador

ASK THE COMMUNITY