Question Multiple monitor setup not working

kronix

Distinguished
Oct 20, 2009
5
0
18,510
0
Hello,

I have a windows 7 computer with 3 monitors setup. It was working fine, however something happened (not sure) and now the 3rd monitor gets no signal/and not detected. All 3 monitors worked together just the other day, and did so for months with no issue.

I have tried unplugging all monitors, turning computer off, plugging one monitor in at a time, but the problem continues. Also confirmed video source. Checked Windows updates/even restored back to previous date, plus updated video card drivers to the latest, but did not help.

If I unplug monitor 1 and 2, and just have 3 plugged in that monitor does work. Once I plug in either 1 or 2 or both in the 3rd goes out (shows no signal message).

Tried replacing the 3rd monitor with a different one using the same cable and it works with monitor 1 and 2.

I'm confused why the 3rd monitor has this problem.

Specs:
GeForce GTX Nvidia 1050 ti
Monitor 1 Samsung TV - plugged into HDMI
Monitor 2 Samsung TV - plugged into DP to HDMI
Monitor 3 Small 11" Eyoyo TV - plugged into DVI on video card to HDMI on TV

If I plug the 3rd monitor into a different device - it works.

Any thoughts or guidance would be appreciated.

Thanks!
 

Lutfij

Titan
Moderator
Please list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor's (make and)model:

Have you made sure you're on the latest BIOS update for your motherboard? Which drivers are you currently on? Might it be possible to pass on a link to the cables used?
 

ASK THE COMMUNITY

TRENDING THREADS