[SOLVED] Multitasking impossible on i7-7700K

Aug 20, 2019
2
0
10
0
Hey guys,

I'm new to the forum, but I tried to do my research, without luck. My problem is somehow more specific as the results I found here.

My specs:
MSI Z170A Gaming Pro Carbon with an i7 7700k on it, 32GB RAM (4x8GB Gskill F4-2400C15D-16GNT), MSI RTX 2070 Armor. Powered by 750 Watt PS.
Triple Display (2x 1080p, 1x1440p)

System and Software stored on a Samsung 960EVO M2
Data and Games each stored on their own 1TB Samsung 860 QVO.

OS: Win 10 Pro on the latest update. Of course 64 bit.

My Problem:

-Scenario1
Division 2 running, average graphic set between medium/high, DX12 active, Vsync and Framelimit to 60fps.
Firefox running, few tabs opened such as Amazon, Facebook etc.
Observation: smooth running game, cpu goes between 30-70%, some higher peaks, but not hitting 100%, no massive framedrops in the game
If now in Firefox I open a twitch stream and go back to the game, my CPU is high on 70-95% and constantly hits 100% which makes it impossible to turn and move in the game

-Scenario2
Same as Case1, but instead of having twitch opend, only Facebook is showing. Again, no issues.
Now I open Streamlabs OBS in order to capture my game, but even in IDLE mode only with no streaming/recording, my CPU goes up to 70-95% again, with lots of peaks to 100%. Again, unable to play....

-Scenario3
No gaming this time, only surfing on Facebook and wathcing a Twitch Stream, not having any issues.
Now that I want to edit some photos, I open Adobe Lightroom, and bam. Constant peaks to 100%. Less than if it was a game, but still remarkable as you can see the mouse moving like the rate was 10fps. This is not always the case in this scenario, but still a constant situation.

I really have no idea what to do anymore. I'm fine with the fact that gaming and using a streaming software on the same device could lead to those issues, but even if the game is on the lowest settings, the problem occurs. In addition, I do not think that it's a common situation that Lightroom + Firefox (with a livestream, not only happening with twitch, but Youtube Live too) cause issues too.

I know that my i7 7700 is "old" regarding tech timing, but still, I'm not trying to render an 8k supernova.

If someone has the golden tip, I'd be so happy to fix this issue.

Cheers
Sven
 
Scenario 1
Whatever your hardware acceleration is set to now try and switch it.
Playing (decoding) a high efficiency codec through the CPU is very demanding while GPUs have special hardware that do that.
https://www.thewindowsclub.com/disable-hardware-acceleration-firefox-chrome

Scenario 2
OBS even when idle by default does the same work as when really streaming except for the uploading.
You can see the setting here,disable encoding while previewing.
Also same as scenario 1 you can use your gpu for the encoding so the impact on the CPU will be next to zero.


Scenario 3
Adobe...nough said.
They read in so many files and use up so many resources that it just happens.
 
Reactions: teralux
Scenario 1
Whatever your hardware acceleration is set to now try and switch it.
Playing (decoding) a high efficiency codec through the CPU is very demanding while GPUs have special hardware that do that.
https://www.thewindowsclub.com/disable-hardware-acceleration-firefox-chrome

Scenario 2
OBS even when idle by default does the same work as when really streaming except for the uploading.
You can see the setting here,disable encoding while previewing.
Also same as scenario 1 you can use your gpu for the encoding so the impact on the CPU will be next to zero.


Scenario 3
Adobe...nough said.
They read in so many files and use up so many resources that it just happens.
 
Reactions: teralux
Aug 20, 2019
2
0
10
0
Scenario 1
Whatever your hardware acceleration is set to now try and switch it.
Playing (decoding) a high efficiency codec through the CPU is very demanding while GPUs have special hardware that do that.
https://www.thewindowsclub.com/disable-hardware-acceleration-firefox-chrome

Scenario 2
OBS even when idle by default does the same work as when really streaming except for the uploading.
You can see the setting here,disable encoding while previewing.
Also same as scenario 1 you can use your gpu for the encoding so the impact on the CPU will be next to zero.


Scenario 3
Adobe...nough said.
They read in so many files and use up so many resources that it just happens.
Thanks for you swift feedback. Will try this later today once back home.
I did mention those 3 scenarios to showcase no matter what I'm doing, CPU is just acting wild. I did not have this problem a year ago while streaming The Division, with SLOBS too. And neither did I face issues developping my photos using lightroom.
Back then my setup was only 16 GB of RAM, and a GTX1070.

I already tried Firefox with/without HW acc. And adatped SLOBS settings to use more GPU power and less CPU.

I'll recheck the settings again if maybe I forgot something.

Cheers
 

ASK THE COMMUNITY

TRENDING THREADS