Mushkin chronos 120gb and slow speeds?

jijoslin

Distinguished
Mar 22, 2010
504
0
18,990
I just received the MKNSSDCR120GB and have not been able to get near the reported speeds. I have downloaded the latest firmware from mushkins site,however I'm still having performance issues. I have a gigabyte z68ap-d3 revision 1 motherboard. In the bios when I try to set up AHCI mode I get a blue screen? Are there any drivers I'm missing? I just did a fresh install of windows 7 on this drive, could some drivers be missing?
 
Solution
Typically this is symptomatic of installing windows BEFORE setting AHCI mode, which will not work.
AHCI mode must be set before installing windows. In your case it is possible to fix this. I don't have the link available right now, but simply google "registry AHCI fix" and you should find a link that shows how to edit the registry to fix the issue.

Your speeds should be fine once in AHCI mode.
Typically this is symptomatic of installing windows BEFORE setting AHCI mode, which will not work.
AHCI mode must be set before installing windows. In your case it is possible to fix this. I don't have the link available right now, but simply google "registry AHCI fix" and you should find a link that shows how to edit the registry to fix the issue.

Your speeds should be fine once in AHCI mode.
 
Solution

darkguset

Distinguished
Aug 17, 2006
1,140
0
19,460


Actually you do not need to do much. There is a simpler method. Revert to standard (non AHCI) mode and boot in Windows.

Open device manager, and go to your IDE ATA/ATAPI controllers and delete them (delete at least the one where the HD is sitting on, but both should work too).

Restart your PC and enter the BIOS (do not let it boot in WIndows).

Now go change the setting to AHCI mode and restart once more.

Let it boot now. Windows should redetect the controllers, but this time in AHCI mode and should work fine now. It may ask you to restart once more.