Question My 1080ti wont boot.

nikexa1351

Commendable
Jan 7, 2019
18
0
1,510
0
Hello everyone. So recently i bought the GTX 1080 ti but it wont boot. When i turn on the pc with the 1080 ti im just stuck at black screen and cant do anything. Ive got GTX 1060 that works just fine in that pc.
What i have done:
Tried diffrent GPU in my pc and it worked.
Tried the 1080 ti in another pc and worked fine.
Changed my psu to 650w bronze 80+

My pc specs:
CPU: AMD Ryzen 5 2600
MBO: msi a320m pro-vd/s
RAM: G.Skill 16GB DDR4 2400 MHz
HDD: 1TB
SSD:Kingston UV400 140GB (OS) and Adata 480GB SSD
OS: Windows 10 Pro
 

nikexa1351

Commendable
Jan 7, 2019
18
0
1,510
0
LC55550 V.2.2 550W. (It has only 1 pcie (6+2) but i used the adapter for other pcie i needed. Didnt work but when i plugged in the 1060 into adapter worked fine)
Azza 650w ARGB PSU (I bought this one as it was the psu i used in the pc that i tested 1080 ti in and it worked there, It is 650w with 2 pcie (6+2)
 
Adapters are an awful idea. If the PSU you use does not have the connections needed to power a GPU then it's not meant to power it and should NOT be used for that GPU.
A 1080ti uses FAR more power than a 1060 so it's not surprising that the 1060 was working (with high risk though).

Your first PSU is NOT a 550w unit. It can output 400w MAX on the 12V rails which is what powers every significant hardware and how modern PSUs are named for wattage. That alone makes it a crappy PSU.

Your second PSU is also crap. 576w max output on the 12v rail. None of these PSUs are good enough to power properly a 1080ti.

Now as for the card was working with the second PSU. I don't doubt it did but you might ended up damaging it with the first one and the second just pushed it to the limit of total failure. That's just a guess.

Can you tell me the exact order you did things and if you tried benchmarking or playing games?
For example: first installed in PC A with these specs... Not working. Then to PC B with these specs.... Working and stress tested for half an hour with heaven benchmark.
 

nikexa1351

Commendable
Jan 7, 2019
18
0
1,510
0
My main pc just doesnt boot with that gpu at all, its 1080 ti strix model that and 2 led lights light white when i plug the pcie cables in but nothing after that. I tried updating bios, uninstalling old drivers etc but nothing worked
 

ASK THE COMMUNITY

TRENDING THREADS