[SOLVED] My ASUS PCE-AC88 Dual-Band AC3100 not working anymore..

maskedterminal

Commendable
Aug 27, 2018
12
2
1,525
1
I don't have the manual.. I must of misplaced it somewhere but I've been using this wifi card for almost 2 years now. Had a few problems with it shutting off here and there but nothing a quick pc restart wouldn't fix. A few days ago it stopped working. Couldn't get anything. I figured it was my files being corrupted so I attempted to do a little restore. (I don't keep anything on my pc besides a few programs and games. All my personal stuff goes onto a external ssd). So I decided to just restore it hoping the problem would fix itself. Nope, In fact, during the process my pc shutdown out of no where and it corrupted my files to the point I had to wipe everything and reinstall my OS. Everything's working but my wifi card now. Idk.. It's been a while since I had to do any pc maintenance so I forgot what it took for me to get my Wifi Card to work when I first installed it but after I cleaned my pc and reinstalled it, the blue light that normally cuts on won't cut on anymore. I don't have an ethernet cable. I kind of gave it to my mother.. So I have no way to really connect to the internet and update my drivers v.v.. but I'm wondering if I even need to update my drivers to get my wifi card to start working. Seems like no matter what I do, it just doesn't want to work. The thing is, whenever it happened I felt the card to see if it was overheating and the heat seemed fine. So I don't think it was the heat. Idk, I'm stumped. I've done everything I can think of.. I'm really hoping it's not something like my mother board acting up.


EDIT: I'm gonna try using the card in my backup pc to see if it works.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS