Question My ASUS Tuf Gaming Laptop is not Using the Dedicated GPU in Games

Jul 6, 2019
1
0
10
0
Yesterday I received my ASUS TUF Gaming Laptop from Amazon.

Here are the specs:
ASUS TUF FX505DY-AL007T 15.6 Inch Full HD Slim Bezel Gaming Laptop - (Black) (AMD Ryzen R5-3550H Quad-Core Processor, RX560 4 GB Dedicated Graphics, 16 GB RAM, 256 GB SSD + 1 TB HDD Storage) https://www.amazon.co.uk/dp/B07MWLLS6Z/ref=cm_sw_r_cp_api_i_CqliDb37FSP8G

Recently I tried to run Minecraft on my laptop which has been running at only 47 FPS on average. And when I pressed F3 to show my frames it said that I was using my Vega 8 graphics instead of my RX 560x?

Things I’ve Tried and Why They Didn’t Work:
  • Disabling my intergrated graphics: I did this and then I tried running Minecraft and it said that my laptop (or GPU I think) doesn’t support OpenGL, but this wasn’t an issue when using intergrated.
  • I installed the new drivers: just didn’t make a difference.
  • Tried installing the old AMD (Radeon) control panel and set it to use the high performance GPU when plugged in AND on battery. But it really didn’t help at all and I continued to have this issue.
  • I tried installing the new AMD Catalyst control panel (drivers 1.9 something I think) and this led to nowhere. Ultimately failing, I tried going to the Windows graphics settings and set Google to a program that needs to use the better GPU. This seemed to work I think because it was running a game called Krunker.io at 120+ FPS but I’m not sure if that was the integrated or the Dedicated. But the thing is the screen did not flash black or anything to show that the GPU changed. And there is no specific ‘Minecraft.exe’ that I know of so this method would not have worked anyway.
If anyone can help me out with this PLEASE do! I’m also going to contact ASUS if this doesn’t work because it could just be becuase if a faulty GPU.
- I deleted my GPU from my devices and then restarted so that I could reinstall it: I’m not sure but I think this may have worked but I’m not sure because when I restarted the fans started going CRAZY but I restarted before I thought to benchmark so I might do it myself again but this would be a temporary solution that I would have to do every time I want to game!

If anybody here knows how to fix this or has had similar problems in the past please help!

Thank you!
Noice
 

ASK THE COMMUNITY

TRENDING THREADS