Question My BIOS and Windows doesn't recognize one of my RAM sticks, but CPU-Z does ?

Apr 7, 2022
1
0
10
0
Guys, recently I bought 2 memory sticks but one of them is not recognized either in Bios or Windows. I tried to change slots, I tried to connect only with it, but nothing worked. I took it to a technical service, and they said the stick was working normally.

Searching a bit I saw a guy with a similar problem, and in his the "defective" stick appeared on CPU-Z, despite not appearing in Windows. As a test I downloaded it and to my surprise, CPU-z recognizes it, screenshots here:

View: https://imgur.com/a/F5AfNMd

So maybe it could be something in the Bios configuration and I have no idea what it is.
The guy i told you abolt solved it by switching the slots both sticks were connected, but for me it didn't worked. I've tried running each stick at a time, the good one boots but the defective one doesn't.

Has anyone seen something similar?

My specs:

Mobo: B450 Aorus M
APU: Ryzen 5 5600G
Ram: Hyper X Fury 8 GB 3600 MHZ
PSU: Corsair CV 650
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

For the sake of relevance,. can you please state the BIOS version for your motherboard? As for you OS, if you're on Windows 10, please mention the version(not edition) of the OS. Which slots are you populating on the board? A2/B2(DDR-1/DDR-2)?


I'd also try and power down the system, disconnect from the wall and then try reseating the sticks of ram in your build.
 

ASK THE COMMUNITY

TRENDING THREADS