[SOLVED] My Blue Snowball iCE

Jan 3, 2019
6
0
10
0
so about last week i got my new Snowball iCE. Then all of a sudden a couple of days ago it stopped working altogether and when plugged in it will turn of my keyboard and mouse. I contacted Blue through email and there website and haven't gotten anything back from them.
 

mtracy1991

Prominent
Nov 6, 2018
500
22
615
38


Did you buy this online?
 
Jan 3, 2019
6
0
10
0


yes i bought this off of amazon
 

mtracy1991

Prominent
Nov 6, 2018
500
22
615
38


It may be defective... That is very odd. Has it worked fine up until it stopped working? Have you tried reinstalling the drivers or swapping usb ports?
 
Jan 3, 2019
6
0
10
0


it worked perfectly fine and the drivers for the snowball arent showing up anymore.
 

mtracy1991

Prominent
Nov 6, 2018
500
22
615
38


Reinstall the drivers from their site. Also, check Device Manager and see if the snowball is being shown.
 
Jan 3, 2019
6
0
10
0


its not in device manager, when i was looking this up i noticed my snowball ice has a different port on the back than others.
 

mtracy1991

Prominent
Nov 6, 2018
500
22
615
38


take a pic and post.
 
Jan 3, 2019
6
0
10
0


 

mtracy1991

Prominent
Nov 6, 2018
500
22
615
38


usb to micro usb... if u have the cable plug it in and problem should be solved. If not, sometimes those cords go bad, so try going to your local Best Buy, Target or Walmart and grab a new one and see if that solves the problem.
 

ASK THE COMMUNITY

TRENDING THREADS