Question My capture card does not work properly on the latest version of Windows ?

Jun 3, 2021
2
0
10
0
Hello everyone, I have had this problem with my capture card for around 5 months now and I am really not sure what the exact problem is.

The capture card I'm using is a Dazzle DVC100, as I am using this capture card to record and stream retro games. It's quite an old capture card, but it had always worked until Late January / Early February 2021. I remember that the night before the capture card stopped working properly I had a big Windows update which is likely the cause. I am not sure what version of Windows I was on before that update, but I am currently on Version 21H1.

The problem I am having is the capture card does not show any picture at all in USB 2.0 ports, and the audio quality is really bad. In USB 3.0 ports, the video shows up however it is very flickery and frames are constantly being dropped, as seen in this video here:
View: https://youtu.be/cBal0fOvsNc
. I had always thought this was a problem with my motherboard, as the motherboard and CPU I am using is currently going through some USB intermittent connectivity issues (B450 Tomahawk MAX with Ryzen 5 3600), however I now have the most recent BIOS update which is said to fix those USB issues.

I decided to use my old PC that has a windows version from 2017 (I believe the windows version is 1709), and the capture card works perfectly using Amarec and the audio sounds great. I decided one day that I should try installing that version of windows on my main PC and it worked perfectly on that version from 2017. I have since updated back to the most recent version of windows because a lot of the programs I use didn't work as well and I am having the exact same problem I always had. Furthermore, on my old PC it automatically updated one day and then the exact same problem occurred on that PC too which has different specs compared to my main PC. They both have AMD CPUs, which I am not sure if that helps.

I am sorry if I explained this poorly, I am very unsure as to what is going on and I find it difficult to explain it. If you need me to list anything else I'd be happy to do so. Thank you so much!
 

Lutfij

Titan
Moderator
I am currently working on an APU build from 2013, the reason I mention that is due to the fact that sometimes windows updates would cripple my system whereby the OS was slow at times and my internet was sometimes unreliable. I solved that by reinstalling the OS after fabricating the bootable USB installer made using Windows Media Creation Tools.

Since you state the capture card is old and that it worked prior to 5 months, will indicate that the drivers are affected. I'd advise on first making sure that your motherboard is on the latest BIOS update. Following that, uninstall your capture card drivers, reboot and then reinstall said capture card's drivers in an elevated command, i.e Right click installer>Run as Administrator.

Also the problem with Windows 10 is that you need to be moving forward not backwards.
 
Jun 3, 2021
2
0
10
0
Im very sorry that I havent replied, I have been quite busy lately. I tried this solution but unfortunately the problem still remains.
 

ASK THE COMMUNITY