Question My computer does not detect 2nd GPU - sometimes

Mar 29, 2022
2
0
10
0
My configuration is Asrock X470 Master SLI, Ryzen 5850X and 2 x 1080Ti.
Till today all worked well with SLI and 2 GPUs - on default UEFI settings.
Today I upgraded CPU from Ryzen 3600 to 5850X and problems arised. After installing it suddenly computer started to detect only 1 gpu - the one in primary slot.
After some Googleing I played with PCI-E lanes settings and result is as follows:
  • x16 - 1 GPU
  • x8x8 - 1 GPU
-x8x4x4 - 2GPU - no SLI in nVidia Control Panel
-x4x4x4x4 - 2GPU - still no SLI

What does it mean? Does MOBO not support more lanes or is it CPUs fault?
I am woried because I felt unpleasent smell when testing CPU with Prime95 - maybe something inside CPU or MOBO got rosted ? Or is it normal? I am afraid it can greatly affect performance.

1200W PSU about 6 moths old Corsair
no iGPU - but each GPU works separately in x16. And both with x4x4x4x4
HDD Samsung 970EVO 512
Windows 11 - updated
Newest drivers from nVidia
 
Last edited:

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Include PSU: make, model, wattage, age, condition (original, new, refurbished, used)?

Disk drive(s): make, model, capacity, how full?

Remove both of the GPU's and, if supported, try using integrated graphics (iGPU).

If iGPU is not supported then use just one GPU and configure as simply as possible. Objective being to successfully boot and have at least one display.

Post accordingly.
 

ASK THE COMMUNITY