Question My computer is lagging on supported games

Jul 21, 2019
9
0
10
0
Hello everyone! I have ReInstalled Ultimate Spider-Man, Spider-Man 3 and Spider-man: Web of Shadows because I wanted to play these old games again. I finished Ultimate Spider-Man (I had some FPS drops in areas but I did not mind the 30 fps I was getting) and started playing Spider-Man 3. The horrible lag from when I started the game amazed me. The only places I didn't have lag were the cutscenes, but I was getting CONSTANT fps drops. Even walking was laggy. I totally have the recommended specs and even checked on CanYouRunIt (a website that tells you if you can run games or not, for people who don't understand how computers work) and had above the recommended specs. I played for a bit but quit trying because I was done with the lag. Then I tried Spider-man: Web of Shadows. I was ALSO lagging on this one too. Then I came here to post my problem. Here are my specs.
CPU:Intel Core i3-5005U @ 2.00GHz 2.00 GHz
RAM:4.00 GB
System:Windows 7, (Cuz I prefer this one) 64-bit
GPU:AMD Radeon R5 M330 and an integrated Intel(R) HD Graphics 5500 (I can't switch then if you want you can help me with this too)
 
Dec 28, 2018
1
0
10
0
i guess the intel card is being used when you play spiderman 3. You need to force Radeon card to be active while playing game spiderman 3. Go in Radeon control panel and spiderman 3 as supported application for the card to work on
 

Phaaze88

Reputable
Herald
3 things come to mind.
1)Being on a laptop, you need the power supply to be plugged into the wall for it to use the Radeon gpu when you play games, otherwise it defaults to the I3's igpu(which is crap, and only really good for flash games) when running on battery.
2)While you have the recommended specs for those games, I don't think that website takes into account the resources used by the OS, which would bump the necessary requirements up a little.
3)Any overheating? Check your temps while playing with HWINFO.
I'm leaning towards #1 here, but I wouldn't rule out #3 though. You should check your cpu & gpu temps to make sure they're not overheating.
 
Jul 21, 2019
9
0
10
0
3 things come to mind.
1)Being on a laptop, you need the power supply to be plugged into the wall for it to use the Radeon gpu when you play games, otherwise it defaults to the I3's igpu(which is crap, and only really good for flash games) when running on battery.
2)While you have the recommended specs for those games, I don't think that website takes into account the resources used by the OS, which would bump the necessary requirements up a little.
3)Any overheating? Check your temps while playing with HWINFO.
I'm leaning towards #1 here, but I wouldn't rule out #3 though. You should check your cpu & gpu temps to make sure they're not overheating.
The laptop is always plugged while I play. The laptop is not overheating (I got it dusted one month ago) and I make sure that before I play I close almost all apps that might slow things down. One thing I need help with is forcing the AMD GPU to get used. I have been trying that all day.(From around 2 PM to around 2 AM, which is right now)I used so many methods that I made a mistake and uninstalled all my Display adapters drivers and had to use 1-2 hours trying to fix that. Right now I am really tired for doing this all day AND I also slept 1 hour and a half so I'm going to give you a few screenshots to see the control panel.
First I tried to start the game and use the AMD control panel and put it on high performance, it kinda works, reducing the lag but it stops after a few seconds and goes back to normal
This is what I do (the game is called Game and I set it on High Performance)
View: https://i.imgur.com/48Sixa6.png

And it goes back to normal after a few settings
View: https://i.imgur.com/FkxPLjn.png

Here is my interface
View: https://i.imgur.com/u0ukLn6.png

(I heard there are advanced setting somewhere but I can't find them)
Here is what my device manger looks like
View: https://i.imgur.com/grXwcxT.png

View: https://i.imgur.com/jf2LwER.png

The preferences tab
View: https://i.imgur.com/Dh5nFq0.png

This is all I can do right now. Thank you for responding and I hope you can help me!
 

Phaaze88

Reputable
Herald
Have you checked bios to make sure it's enabled? Look over everything graphics related, even power saving settings.

Go back into windows power plan, and check the advanced settings of the high performance power plan for anything related to the igpu/gpu.

Have you tried playing any newer/more recent games, and does it behave the same?
 
Jul 21, 2019
9
0
10
0
Have you checked bios to make sure it's enabled? Look over everything graphics related, even power saving settings.

Go back into windows power plan, and check the advanced settings of the high performance power plan for anything related to the igpu/gpu.

Have you tried playing any newer/more recent games, and does it behave the same?
Have you checked bios to make sure it's enabled? Look over everything graphics related, even power saving settings.

Go back into windows power plan, and check the advanced settings of the high performance power plan for anything related to the igpu/gpu.

Have you tried playing any newer/more recent games, and does it behave the same?
I tried to enter the bios . I close my pc and press insert / delete until I enter the Boot Manager but there are only 2 options. Start Windows 7 (or something like that) and to check the system's integrity.

I opened a more recent game and found a new thing (still doesn't save the High performance)
It shows my "dedicated" GPU bellow the name of the proccess (dnftm is the new game)
View: https://i.imgur.com/nziO9MP.png


And here are the power options
View: https://i.imgur.com/LWXkF26.png
 

Phaaze88

Reputable
Herald
I'd imagine you should change it back to maximize performance. Where the R5 M330 is concerned, power consumption is higher, so you want to throw power saving options to the curbside. Optimizing performance would set it to use the cpu's igpu more often.
What's in the Lenovo Energy Management tab though?
The trouble you're having is likely some BS they set up.

Do you have any newer games you can try? The games you have mentioned are 10+ years old, and the laptop is from 2015. It may behave differently with a more recent title.
 
Jul 21, 2019
9
0
10
0
I'd imagine you should change it back to maximize performance. Where the R5 M330 is concerned, power consumption is higher, so you want to throw power saving options to the curbside. Optimizing performance would set it to use the cpu's igpu more often.
What's in the Lenovo Energy Management tab though?
The trouble you're having is likely some BS they set up.

Do you have any newer games you can try? The games you have mentioned are 10+ years old, and the laptop is from 2015. It may behave differently with a more recent title.
I have a game from 2009 and it runs pretty smooth. It's called Prototype but I also have Prototype 2 but It barely works.
And another one called Burnout Paradise from 2008
I don't even try to buy any newer games because they lag and then I thought maybe my laptop was using the wrong GPU so I came here.
The lenovo energy management only helps with the battery runtime and stuff. I checked the settings but it doesn't interfere with anything. The only option I can think of changing is to max out the performance settings for the GPU but that's all.
 
Last edited:

Phaaze88

Reputable
Herald
Ok, what I'm seeing here... (please correct me if I read wrong)
The R5 330 is running just fine with Prototype 1 and 2(performance is poor here due to requiring a stronger setup.
When you try to play those Spiderman games, they instead run on the Intel igpu.

If there are any options in LEM that relate to power saving, change them to maximize performance. Same deal with those power options in your previous post. You're telling the machine to screw power saving. Maximizing battery life/optimize performance = igpu.
Throwing power saving out the window also means higher temps, so keep an eye on that.

If that doesn't work, then the issue is probably something on the bios level that Lenovo set up.
 
Jul 21, 2019
9
0
10
0
Ok, what I'm seeing here... (please correct me if I read wrong)
The R5 330 is running just fine with Prototype 1 and 2(performance is poor here due to requiring a stronger setup.
When you try to play those Spiderman games, they instead run on the Intel igpu.

If there are any options in LEM that relate to power saving, change them to maximize performance. Same deal with those power options in your previous post. You're telling the machine to screw power saving. Maximizing battery life/optimize performance = igpu.
Throwing power saving out the window also means higher temps, so keep an eye on that.

If that doesn't work, then the issue is probably something on the bios level that Lenovo set up.
I presume you are right, because I was asking myself why Prototype 1 was working better than the Spiderman games and Burnout Paradise even though they work on lower setups. I think that some games select my actual GPU instead of the integrated one. But I have played Sniper: Ghost warrior 2 recently and I think I have the same problem. I had to set my graphics on Low even though I have the required specs. The game was launched in 2013 and it shows the same problems as the Spiderman games and Burnout Paradise.
 
Jul 21, 2019
9
0
10
0
Okay, I've found out how I'm SUPPOSED to switch the GPUs. I need to go in my AMD setting, System and change the profile of the game I want to play from "Power Saving" to "High Performance". I try to do that, but the profile turns back to Power Saving after a minute or so.
 
Jul 21, 2019
9
0
10
0
Looked around a little bit and found these:
Configuring Laptop Switchable Graphics on a Windows® Based System
Laptop graphics update...How to (skip the part about laptops with AMD cpus/apus - what you have is below that)
Run gpu-z while you game, it should tell you which is being used. https://www.techpowerup.com/gpuz/
I have tried to reinstall the drivers yet I still encounter the same problem.
I don't really know how to use GPU-Z but it shows that the actual GPU is not heating up whatever I do, the integrated one is . I have also sent an email to AMD support to see if they can help me.
 

ASK THE COMMUNITY

TRENDING THREADS