Question My computer turn on and off, then turns on then nothing

Oct 21, 2019
2
0
10
0
So uh I kinda did a stupid mistake this morning and uh, plugged my amd Sapphire Pulse RX570 to a molex plug and tried to run it, I heard a click then a burning smell. I quickly shut down my system and removed the plug.

After the disaster has happened I tried to boot my PC without the card and all it does is turn on for a couple of seconds then turn off then turn on indefinitely with nothing on the screen. I know I killed something in my pc but I don't know which, my PSU's fans are working so I assume my PSU is working even my cooler on my mobo is turning on but It don't do nothing.

Someone please help me determine which of these two are the ones causing a problem and is my video card killed in the aftermath? I'm a poor boi so I don't have a huge allowance so I want to replace the right part rather than replacing something still working. Thanks for reading.
 
Last edited:
Oct 21, 2019
2
0
10
0
full system spec? include make and model of the psu
if the psu is that old that don't have the pcie power. replace it
Intel core I7 Gen 3 (forgot what I7 its is tho)
Asus P8Z68-M Pro Motherboard
8 GB of Ram
2.5 TB of Storage (3 HDD)
Thermaltake Toughpower XT 775 Watts PSU
AMD Sapphire Pulse RX570 8GB
The case is an old case from 2007 so I forgot what case it is but there was an old Pentium in it when I got it.

I don't really know why it happened tho I'm pretty sure plugging a GPU to a molex is a common solution if you're lacking 8 pins for video cards. It happened when I plugged it in with all of the hard drives already connected to a molex port.
 

ASK THE COMMUNITY