[SOLVED] My computer turns on but won't show up on my monitor

Dec 29, 2019
2
0
10
0
I'm new at building computers this is my first build, I put everything in and then it turns on fans start spinning then it turns off and beeps, then turns on. Then it does it again, and then it becomes stable but it won't show up on my monitor. It says that there is no connection. I switched around the ram, and still no luck. I don't know what's wrong and I just want to find what's wrong so I can use my computer
 

NightHawkRMX

Illustrious
I must have missed this thread.


Yes, the i7 6700k is 5 years old and will not work with z390 motherboards even though the spcket is the same.

I would sell the 4 core i7 and buy a new 9th or 8th generation 6 core i5 at least.
 

NightHawkRMX

Illustrious
Dec 29, 2019
2
0
10
0
Full system specs?

MasterWatt 750 Watt Semifanless Modular Power Supply, 80 PLUS Bronze Certified Power Supply for Computer

NZXT H500i

ASUS GeForce GTX 1070 8GB Turbo Edition


Seagate BarraCuda 2TB Internal Hard Drive HDD

Cooler Master Hyper 212 Evo CPU Cooler

Intel Core i7 6700K

CORSAIR Vengeance RGB Pro 16GB (2 x 8GB)
ASUS ROG Maximus XI Hero (Wi-Fi) Z390 Gaming Motherboard LGA1151

Kingston 480GB A400 Sata3 2.5" Internal SSD
 

NightHawkRMX

Illustrious
I must have missed this thread.


Yes, the i7 6700k is 5 years old and will not work with z390 motherboards even though the spcket is the same.

I would sell the 4 core i7 and buy a new 9th or 8th generation 6 core i5 at least.
 

ASK THE COMMUNITY