Question My computer won't power on

Dec 13, 2019
1
0
10
0
2-year old build.
Ryzen 5 1500x, stock cooler, plugged in.
Seasonic 430 watt /EVGA 400 watt PSU (Tried both)
EVGA gtx 1050 SC
2133 and 2400 mhz Crucial Ballistix Sport RAM, 8gb each, 16 gb total
And the most important part
Gigabyte GA-AB350 Gaming 3, Rev. 1.0

This problem is interesting. I installed the Cpu fan, cpu, ram, (Gpu doesn't matter for this issue), and both 8 pin and 24 pin Powe Cables. AFTER turning off the PSU, unplugging it, replugging it, then turning on the PSU, then shorting the power pins, the fans spin for 1/8th of a second and the cpu light flashes - and doesn't flash again after that. The glow strips the motherboard has don't light up. In fact, the only sign of life is a USB mouse that glows while connected to the USB port on the Mobo. After the cpu light blinks, trying to turn off the Mobo and turn it back on won't result in the light blinking again, only turning off the PSU, unplugging it, replugging it, turning on the PSU, and shorting the pins yeilds another flash from the cpu light, and nothing after that.


However, if all of the above was performed, minus the 8 pin power connector, the fans spin properly, the GPU and Cpu fans spin properly, the Cpu light is stable on, and two other white lights blink like the cpu light did when the 8 pin Power cable was connected (to the motherboard, the PSU isn't modular.)

I tried cleaning the cpu pins (none of the pins are broken or bent) , the socket, or anything else, in case that was the issue.


I tried resetting the Cmos, and taking out the battery, as I know Gigabyte boards have a soft brick issue, but if there's any other way to reset the Cmos that would probably help.

I tried every stick of ram in every slot, I tried using the case power switch, I tried the cpu out of the socket, I tried the gpu in, the gpu out, and I'm so confused as to what the problem is.

Also, my cpu doesn't have enough themal paste - it's nearly flaking off. I cleaned my socket for that reason, in case any got in.

One final note - I tried this without the cpu, cpu fan, or 8 pin, the fans spun, and the light flashed on cpu then switched to dram for some reason.
 
Aug 6, 2019
28
3
45
2
definately seems like a cpu or a socket issue. do you have access to another socket am4 board to test the cpu on? if not, maybe pull it and take it into a local repair shop and see if they can check it for you.

have you recently tried updating/flashing the bios?
 

ASK THE COMMUNITY

TRENDING THREADS