My CPU I7-6700K runs about 90 degrees celcius or more when idle!

ceasefire95

Reputable
May 22, 2015
23
0
4,510
0
Hi guys

I really need your help here. I got an I7-6700k CPU that is not overclocked, with an X62 280mm Kraken as a cooler. When I first got the cooler i worked perfectly fine runing at about 30 degrees idle. Then all of sudden it went up to the 90 degrees and I have no clue what is wrong. It's so bad at the moment that my BIOS wont even let me access windows due to too high CPU temperatures. I have re-applied the thermal paste twice now to make sure its fine to no help. I have double checked all the fittings, CPU Fan controller and so on as well as checked that the pump is running, but everything seems to work as it should. I did notice tho that I started having problems after installing the NZXT Cam software and that might be the problem. Anyone know what might be wrong? Could really use some help!
 


Could be that the pump died. Does it vibrate in any way when the pc is turned on?
 

Seanie280672

Estimable
Mar 19, 2017
1,958
1
2,960
599


Is the water block or pipes down by the water block getting hot ?

 

ceasefire95

Reputable
May 22, 2015
23
0
4,510
0


Let the PC stand quiet for a bit and finally got into Windows. Logged into CAM and saw that the Pump RPM was at 0. So yea, looks like the pump might have died. Anything I can do ? Other than getting a new cooler?
 

Seanie280672

Estimable
Mar 19, 2017
1,958
1
2,960
599


RMA it if its still under warranty, or you need a new cooler.

 

ceasefire95

Reputable
May 22, 2015
23
0
4,510
0


Alright, thank you!
 

ASK THE COMMUNITY