Question My CPU is having problems

Jan 20, 2021
3
0
10
0
So I recently bought new RAM to upgrade my pre-built PC. My specs are...
Ryzen 7 2700x
RX 480 4GB
16GB DDR4 RAM
MSI A320M-A PRO
500W Power supply

My problem is, is when I have my PC running for too long it shuts off. It barely has a minute before it shuts off if I am lucky. It varies between 10
seconds and about 60 seconds. It acts like it’s overheating because when I add an extra fan blowing out of the internals with the glass screen off, it lasts longer. But on inspecting the temperature while I wait a couple minutes after a shut down, the temperature only goes to about 40° to 80° C. After I wondered if it was because I added more RAM, I swapped the 16GB (8x2) with the original 8GB. But the problem still occurs where the PC shuts down. I had enough time with just the 8GB of RAM to run the userbenchmark test and it showed that my CPU was running on about the bottom 10% percentile or so. Can someone give me suggestions on how I can fix this? The only thing that could be the problem is the CPU fan clips that hook onto the CPU are slightly too small so I can only hook on one side. I hook on the top one and position it right on top of the CPU as it would if the bottom was clipped on to and it stayed in position, but that was never an issue before.
edit: I am newer to PC so I do not know very much about this kind of thing
 
Last edited:
Jan 20, 2021
3
0
10
0
check the cpu temp?
what the model of this 500w psu?
It is a 500W Cooler Master power supply (MASTERWATT LITE) but it hasn’t given me issues before.
the cpu temp exactly is 25°C before it just shut off. I just turned it on after all night of being off
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS